TPG Community

Get online support

How do I upgrade firmware on Huawei HG659

SOLVED Go to solution
Level 2


I am having problems with port forwarding 80 and 443.  I know how to port forward and do it successfully with other ports, but 80 and 443 will not go anywhere else other than the HG659 web admin.  I have rebooted the modem repeatedly Smiley Happy


Is there a firmware update available for my modem? 

Product type: HG659
Device ID: 00E0FC-J3N8W17825953594
Hardware version: VER.B
Software version: V100R001C216B112


According to other posts i have read on this forum, I should be able to forward 80 and 443.  If a firmware update doesn't fix this, then maybe my modem is faulty.


Thank you,




Hi @hansenma,


Welcome to TPG Community!


We have located the account using your community details.


We have requested a firmware upgrade and we'll be in touch as soon as an update is received.


Hi @hansenma, the firmware has been upgraded.


Please be advised that we don't block ports.


Should you need any assistance, feel free to message us. Thank you.

Level 2

Hi @Riezl , 

Thanks for upgrading the firmware but that did not fix the problem.

please note - I did not say the ports were being blocked, I said that the modem will not forward ports 80 or 443 to a computer within my home network.  I have forwarded other ports successfully but 80 or 443 will not go to any other machine except the router.


Do you have a solution for this?

Thank you

Level 2

Hi Support - so here I am nearly 2 weeks later and the saga continues. I've spent untold time speaking to support people - have taken a day off work and traveled from brisbane 92 hours) to let the TPG guy "look" at the modem - what a waste of time. YES! - I have disconnected / rebooted etc. I have now driven from Brisbane again for a supposed NBN appointment on Friday but still no confirmation - I REPEAT FOR ANYONE WHO ACTUALLY PUTS SOME THOUGHT INTO FEEDBACK SUCH AS THIS - THE PROBLEM STARTED WHEN THE NBN GUY WAS "PLAYING" IN THE TELSTRA PIT. Yes I know that there is a process but to follow it blindly is pointless!! - some response would be good

Tom C.



Hi @tech91


We have replied to your thread advising you that we have re-escalated the case back to our Engineering Team for assistance. Updates will be provided by them via SMS or phone call.


Should you have other concerns, let us know.



Level 2


 I guess like me you cannot access your own website from your own local network. w ww!whatever!com!au and the Hawai Gateway shows up for the modem when you access locally. You so have the latest firmware I checked today for you. So an update wont solve my or your problem, so thanks Smiley Happy....
I think this is the problem: Tpg do not block ports but I think this modem acts like a proxy in the way to your network passing throu these ports. This is a very non-standard thing. I guess this is so they can push updates and check settings, access your network for consumers that know little, a good way to help but...
I'm just guessing, but wait till you try get a SSL certificate you get

Your connection is not secure The owner of w ww.whatever! has configured their website improperly.
To protect your information from being stolen, Firefox has not connected to this website. Learn more…

Report errors like this to help Mozilla identify and block malicious sites w ww!whatever!com!au uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.

The certificate is only valid for the following names:
mediarouter.home, mediarouter1.home, mediarouter2.home, mediarouter3.home



Thats the router answering when the SSL was requested.......not your website.

How to fix?: Ditch this modem. Its behaviour is non-standard and not appropriate for business purposes.


Or TPG am I wrong is their another fix? Am I missing something obvious....?


Level 2

Hi Team,


May I request my HG659 upgrade to latest Firmware? 

Product type:
Hardware version:
Software version:

Hi @yangyang5973,


Welcome to TPG Community!


We have already requested a firmware upgrade and we'll advise you once it's completed.


Hi @hansenma, we are investigating this and we will provide further updates by mid next week.