TPG Community

Get online support

ADSL2+ speed has dropped again

Level 1a


For the last 48hrs or so my speeds have dropped down to 1Mbps and under. This happened back in February as well so I've tried all the fixes and tests to no avail;

-restarting modem

-all light indicators work

-no dial tone when phone plugged in

-tried both wifi and wired connection

If its any help the precise dates were the 21/02 and 22/02 I was in contact with the TPG team about this which was fixed on their end so I'm hoping the same the can be organised.

With Thanks


Hi @arl92,


Welcome to TPG Community!


We have located the account using your community details. We have checked the status of your connection and we are not detecting any fault on the line that may affect the speed at the moment. However, we have arranged a technical specialist to contact you between 10:30AM and 1:30PM Victoria time today for assistance.


Should you have a preferred contact number and time, please send it via PM.


To send a PM, please refer to this link: How do I private message (PM) in the community


Hi @arl92, thanks for sending your contact details via PM. We have rescheduled the callback between 6PM and 7PM instead.


Hi @arl92, we can see that our Technical Team has been in touch and the issue has been escalated to our Engineering Team. They are working on sending a Telstra technician to investigate further and an update regarding the schedule will be provided by the case engineer via SMS or a phone call.


Should you have further queries, please let us know. Thank you.