TPG Community

Get online support


Level 3


I have read a lot about how to get the router ax88u working with NBN and all cases the information given was ridiculous. 

Things like activating double WAN or setup a VLAN, etc...

I am going to tell you how to make this router getting the data (accesing the internet) from the NBN NCD.


Login into the router

Quick Internet Setup

Internet connection type: PPPoE

Tick on Special Requirement from ISP. (This step is the most important one where everyone misses)

(You will then have a list of ISP and select TPG)

Enter your username and password (not for router but for the TPG account)

You are done.

Now you can use the router that TPG sent you as an extender if you know how to configure this.

Not sure the level of knowledge TPG engineers have, but on the online chat the engineer told me to use the RT-AX88U as a backup modem!!!. a $550 "modem"! vs the archer.

First of all, it is not a modem. the RT stands for router. The modem supplied by TPG is a modem/router. but the actual modem is the NBN Network connecting device (NCD). TPG's "modem" is used as the router.

I am a network engineer myself. The service provided by TPG is fantastic but at this moment in time everybody should calm down a bit and have more understanding about the work they are doing under these circustances.




Level 2

Thanks for the detailed  information and setup.Just conforming NBN connection-Is that NBN Fibre to the Premises (FTTP) connection setup as i am using this sort of connection.Before buying the new router ax88u;just want to confirm connection setup..

Many thanks.

Level 2

I called TPG FTTB support apparently the setup instruction is not for us. I'll keep trying to find the solution since I already have RT-AX88U. If anyone else finds a solution could you please post it here?

Level 2

just wondering if there is an update to this thread

i am also considering purchasing an AX88U and using it for my TPG NBN connection

anyone get it working with FTTP?


Level 2

Thank you so much for posting the solution.


After 3 hours of trying....your solution worked.


Before following your steps I needed to upgrade the firmware. For that I had to first use my old modem router to download the Firmware....then connect to the ASUS router (obviously without internet...but just connect to the router) and then followed the steps recommended above and it worked.


The Tech Support had no clue on this.