TPG Community

Ask, answer and talk about our products

Update: KRACK WPA Security Flaw

Community Manager

Hi Guys,

Just an update on the KRACK WPA security flaw that has been in the news this week.

 

We have worked with our suppliers to confirm that the below modems are not affected by the KRACK vulnerability:

  • Huawei HG532d
  • Huawei HG658
  • Huawei HG659
  • TP-Link Archer C1200

 

The TP-Link Archer VR1600v may be affected if you manually configure and use the Wireless Distribution System (WDS) function. The WDS function is disabled by default. We are working with our supplier on a solution. We strongly recommend that customers do not use the WDS function until further notice.

 

We are working on confirmation regarding TPG-supplied Netcomm modems and will provide an update as soon as it is available.

 

We strongly advise customers to download the latest security updates for their WiFi enabled client devices (mobile phones, laptops, tablets).

 

4 REPLIES
Level 3
Thanks for the update @Manuel.
--
Regards,
Enterprise Administrator
Level 1

I have a Huawei HG630 from a FTTB service. Will this be getting a firmware update and is it affected by the KRACK flaw ?

Level 2

I also have a Huawei HG630 and would like to know the situation re KRACK.

Level 2

Thanks for the phone call re this matter.