TPG Community

Ask, answer and talk about our products

Very poor ADSL2+ speed

Level 1a

Hello. 

I have been experiencing some very poor download speeds of late. At present speedtest is showing less than 1MB\sec. It is much closer to .5MB\sec. I have experienced much faster speeds using the current modem \ PC \ line in etc. Nothing has changed since experiencing much faster speeds. I would expect something in the 3-5MB\Sec rage would be considered normal as that is what speed i am referring to when i say i have had much higher speeds previously. I can see others have \ are having a similar issue.

I have been an account holder for many many years. And a happy one at that. However of late with the low speeds it is raising a question of "am i getting the best service available?"

Can you please advise further on the speed issues and assist in trying to get back to a half reasonable speed. 

Thanks in Advance. 

3 REPLIES
Level 2

hey mate sounds extremely similar to my experiences this week. When did yours start with <1mb speeds? Started for me Tuesday/Wed this week. Im eastern suburbs melbourne (Bayswater exchange) 

Level 1a

Yes been for about a week or more. Im in Brisbane

Moderator

Hi @smith_79

 

Welcome to the TPG Community.

 

We can see that the issue has been escalated to our Engineering Team and they're now working on sending a technician to further investigate the issue. The Team will be in touch via SMS or a phone call as soon as the schedule becomes available.

 

Nevertheless, we'll make a follow up to ensure that a technician will be dispatched as soon as possible.

 

Let us know should you have further queries. Thank you.