TPG Community

Get online support

5G Home Broadband keep connecting to 4G instead of 5G

smypadm11
Level 2
Hi I just got the Sagemcom Fast 5866t 5G yesterday(13/04/2022) as an upgrade from my NBN. At first, it was connected to 5G as the indicator shows green with 3 bars, but after awhile it turns to 4G and the indicator shows yellow with 3 bars. After a restart, It sometimes goes back to 5G for awhile and then it turns back to 4G. The 4G connection is way slower then my NBN connection, so if this is unfixable might as well cancel the change to 5G. Any suggestions on what I should do to force the modem to stay connected to 5G?
7 REPLIES 7
Angeli
Moderator

Hi @smypadm11

 

Welcome to TPG Community! 

 

Have you tried to move the modem on another spot in your house which is near a window? What speed do you usually get? 

 

-Angeli 

smypadm11
Level 2
Yes I have tried moving it into several spot. This spot is the only one that get 5G. The other spot are always on 4G. When it's 5G I can get around 98Mbps which is okay because I got the up to 100Mbps. but when it's 4G I only get around 17Mbps while my NBN50 I will always get the full speed 50Mbps.
Angeli
Moderator

Hi @smypadm11

 

Are you now able to get 5G signal? How's the speed so far? 

smypadm11
Level 2
No It's still on 4G, I have restarted the modem for a lot of times and now it's just connected to 4G. Haven't got 5G yet for several hours now
Angeli
Moderator

Hi, 

 

Can you please send me a private message with your TPG account number and callback details? I'll have a tech specialist to ring you for further troubleshooting. 


How do I private message (PM) in the community
 

Regards,

Angeli

 

MatJones
Level 2

Hi Angeli,

 

Was this resolved?

I've been having the same issue for a number of weeks now.

 

5G connection is fine, but then after a while, reverts to 4G connection & requires a restart in order to get the 5G connection again.

 

I've also tried the router in different positions, but the same thing seems to happen regardless.

 

Cheers,

Mat

Ahra_G
Moderator

Hi @MatJones

 

If you are experiencing issues with your service, do send us your Customer ID/Account number so we can also have a look at your service. 

 

Thanks! 

Ahra_G