TPG Community

Ask, answer and talk about our products

ADSL 2+ speed degrades over hours and days and drops out intermittently

Level 1b

Hi,

Currently, my ADSL 2+ connection is sitting at 1.2-1.7mbps. When I have called support over the years, they run through the usual questions & do the usual checks. They get me to take the phone cable out of the router phone port and connect it in one of the network ports for a minute or two. then back to the phone port. After repeating this a couple of times, my speed jumps to around 5-6mbps. My speed remains up there for a barely a few days, then over time, it drops to 3mbps, then 2mbps, then to where it's at now. A couple of times it's dropped to below 0.8mbps sparking much frustration and annoyance. This issue seems to be a very common theme across many TPG customers

I've tried power cycling the modem with no difference in speed. Please help. I'm seriously considering going with another ISP especially as NBN is being rolled out soon in my area. Further, I'm aware of other options I have as a paying customer where the service provided is not as advertised and has not been fixed promptly previously.

 

Thank you.

1 REPLY
Moderator

Hi @rajarshi81,

 

Welcome to the community!

 

I would love to help and see what causes slow connection on your service.

 

I'd like to know on which device(s) you experience this issue and if it is possible for you to post a speed test result on this thread. That would help.

 

Kindly PM me your account details (Username/Customer ID or Contact number associated with the account). for reference.

 

Cheers!