TPG Community

Ask, answer and talk about our products

Battlenet Launcher slow

Level 1c

Hey guys i've got HFC TPG and getting 90/38 speedtest results from speedtest.net and fast.com however my battlenet launcher is very slow at downloading games/updates. I can download from steam/origin fast but on battlenet i get around 700kb/s to 2mb/s max. This didn't used to be the case. I don't have any setting to throttle or limit the speed in battlenet enabled nor am i using a firewall. When hooking my computer to 4g i get fast speeds so it's not the blizzard servers. Thinking it's a potential routing issue with TPG and battlenet.

 

Cheers

9 REPLIES 9
Moderator

Hi @Coldplayer

 

Thanks for raising this with us.

 

For us to better understand the reason for the latency you're experiencing when you're playing the game, can you post your traceroute results for the game server?

 

Regards,

Will

Level 1c

Hi it's not ingame but when downloading games.

https://us-looking-glass.battle.net/

 

When i run this i get.

 

 

TRACEROUTE:
traceroute to 220.244.125.253 (220.244.125.253), 15 hops max, 60 byte packets
1 Blizzard Blizzard 0.370 ms 0.366 ms 1.179 ms
2 24.105.18.3 (24.105.18.3) 1.201 ms 1.201 ms 1.223 ms
3 137.221.105.16 (137.221.105.16) 1.226 ms 1.228 ms 1.240 ms
4 137.221.66.22 (137.221.66.22) 1.242 ms 1.244 ms 1.234 ms
5 137.221.83.68 (137.221.83.68) 13.059 ms 13.073 ms 13.076 ms
6 137.221.65.68 (137.221.65.68) 12.880 ms 12.957 ms 12.950 ms
7 137.221.65.1 (137.221.65.1) 12.826 ms 13.253 ms 13.238 ms
8 137.221.65.7 (137.221.65.7) 13.057 ms 12.914 ms 12.901 ms
9 137.221.70.34 (137.221.70.34) 13.033 ms 13.158 ms 13.487 ms
10 * * *
11 203-221-3-108.tpgi.com.au (203.221.3.108) 159.670 ms 159.666 ms 159.668 ms
12 aspcom.com.au (220.244.125.253) 169.680 ms 169.338 ms 168.979 ms

 

 

Moderator

Thanks for providing the traceroute results, @Coldplayer. To clarify, was this done using a WIFI connection?

 

We may need to check the account to look into this further. We tried to pull up a record using your community details, but we're unable to find a match. Can you PM us your customer ID or username along with your service address?

 

For your reference: How do I private message (PM) in the community

 

Can we have a traceroute result as well for tpg.com.au for comparison? In addition, may we have the results as screenshots (which means we'd like you to run another traceroute from the game server) instead of performing a copy/paste? The screenshots should include the computer clock so we know when the test was performed.

 

 

Level 1c

https://imgur.com/a/DI8pxBM

 

TRACEROUTE:
traceroute to 220.244.125.253 (220.244.125.253), 15 hops max, 60 byte packets
1 Blizzard Blizzard 0.302 ms 0.305 ms 1.099 ms
2 24.105.18.131 (24.105.18.131) 0.593 ms 0.664 ms 0.754 ms
3 137.221.105.12 (137.221.105.12) 1.100 ms 1.105 ms 1.110 ms
4 137.221.66.16 (137.221.66.16) 1.397 ms 1.413 ms 1.492 ms
5 137.221.83.66 (137.221.83.66) 13.080 ms 13.113 ms 13.100 ms
6 137.221.65.68 (137.221.65.68) 12.909 ms 13.422 ms 13.391 ms
7 137.221.65.1 (137.221.65.1) 16.058 ms 16.083 ms 16.077 ms
8 137.221.65.7 (137.221.65.7) 12.841 ms 12.950 ms 12.939 ms
9 137.221.70.34 (137.221.70.34) 13.083 ms 12.853 ms 12.864 ms
10 * * *
11 203-221-3-44.tpgi.com.au (203.221.3.44) 159.717 ms 160.833 ms 161.909 ms
12 aspcom.com.au (220.244.125.253) 171.042 ms 171.056 ms 170.597 ms


29/10/2019 12:49:04 UTC
--------------------

PING:
PING 220.244.125.253 (220.244.125.253) 56(84) bytes of data.
64 bytes from 220.244.125.253: icmp_seq=1 ttl=53 time=167 ms
64 bytes from 220.244.125.253: icmp_seq=2 ttl=53 time=167 ms
64 bytes from 220.244.125.253: icmp_seq=3 ttl=53 time=167 ms
64 bytes from 220.244.125.253: icmp_seq=4 ttl=53 time=168 ms

--- 220.244.125.253 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 167.053/167.798/168.874/0.847 ms


29/10/2019 12:49:04 UTC
--------------------

MTR:
Start: Tue Oct 29 12:49:03 2019 Blizzard 1.|-- Blizzard 0.0% 10 0.3 0.3 0.3 0.3 0.0
2.|-- 24.105.18.131 0.0% 10 0.6 0.7 0.5 1.6 0.0
3.|-- 137.221.105.12 0.0% 10 0.8 1.0 0.8 1.2 0.0
4.|-- 137.221.66.16 0.0% 10 1.3 7.6 0.9 52.6 16.3
5.|-- 137.221.83.66 0.0% 10 13.0 17.1 12.7 55.5 13.5
6.|-- 137.221.65.68 0.0% 10 26.3 17.3 12.8 38.4 8.6
7.|-- 137.221.65.1 0.0% 10 12.9 29.4 12.8 110.2 34.1
8.|-- 137.221.65.7 0.0% 10 12.9 14.6 12.8 28.1 4.7
9.|-- 137.221.70.34 0.0% 10 13.1 14.0 12.9 21.4 2.6
10.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0
11.|-- 203-221-3-44.tpgi.com.au 0.0% 10 159.7 159.7 159.7 159.8 0.0
12.|-- aspcom.com.au 0.0% 10 170.9 168.8 167.0 172.3 1.7


29/10/2019 12:49:03 UTC
--------------------

I'm running the blizzard one from here so can't screenshot with all the results. I'll pm you my details.

 

https://us-looking-glass.battle.net/

 

 

Moderator

Hi @Coldplayer

 

Thanks for providing your details via PM and also for the results you've provided. However, we need you to perform the traceroute via the command prompt (Windows) or through the Network Utility on a Mac. The reason for this is we need to get the result from the local network going to the game server and not the other way around.

 

 

Level 1c

Hi i'm not sure what the server address to tracert or ping is. My main issue is with battlenet downloader but i can't figure the address. When i go through nordvpn on battlenet downloader i go from 1mb/s to 6mb/s. When i go from my hotspot i'm also getting about 6-8 as well. Definitely an issue with TPG.

Moderator

Hi @Coldplayer

 

I understand that using a different network allows you to download faster than when you use your TPG connection directly. However, we're not detecting any network issues at the moment, hence why we need the traceroute result, so we'll have a better understanding on what to look into. Furthermore, the transfer rate you posted is actually well within the expected threshold for the plan. We suggest that you check with the game's support first or at least get the specific URL or IP address from them so you can run the traceroute.

 

 

Highlighted
Level 1c
Hi so i realised i've got the exact issue with downloading drivers from nvidia website so think it's easier to diagnose than battlenet. When i download without VPN i get 2mb/s then with NordVPN i get 9mb/s. I've run tracert and ping on TPG and Nord. https://imgur.com/a/Oux6xGH - NordVPN https://imgur.com/a/TROqsTz - TPG without VPN. Both these sites are American, ping seems similar but download speed is very different. Cheers
Moderator

Hi @Coldplayer,

 

Thanks for posting the test result. We'd like to confirm if the transfer rate you're getting at the moment is the same as in your initial post (90/38 speedtest).
 

As advised of my colleague above using a different network may allows you to download faster than when you use your TPG connection directly. Also, the Tracert result clearly shows that there is a latency issue but it is outside of TPG's network.

 

I also ran an initial test to the service and at the moment it is connected for 1week 2d 8h 30m with a passing speed on the line.

 

Regards,