TPG Community

Get online support

Battlenet Launcher slow

Highlighted
Level 1c

Hi, sorry haven't replied here since i tried dealing with forum_admin@tpg.com.au for a faster response but have had no luck with them. Yes i am still getting those speeds but downloading anything from a non Australian server i don't ever get 2mb/s or above.. I've tested this on a different pc on my network without nordvpn installed too.

 

https://imgur.com/a/rFLSoys

 

Highlighted
Moderator

Hi @Coldplayer,

 

Thanks for the additional details. Based on the tracert result clearly shows that there is a latency issue but it is outside of TPG's network.

tracert.png

 

Cheers!

Highlighted
Level 1c

If it's a problem outside the network then how come as soon as i swap to telstra 4g i can get 5-8mb/s from 200kb/s?

I'm at work at the moment which has a gigabit tpg fibre link and am getting 29mb/s easily.

 

https://imgur.com/a/sFER5un

Those are the results from my work.

 

How come with Telstra 4g/different TPG line it works fine but only on my home connection it's stuck at 200kb/s? It's not just on the nvidia site either but this is just the easiest example i could give you.

Highlighted
Moderator

Hi @Coldplayer,

 

Yes, the download speed you're getting at your Office Network may be faster it depends on your Office Network speed also, the Tracert result shows the same with the previous test using your TPG Network. For testing and reference purposes please post a speed test result (www.speedtest.net) using your office networ.

 

Regards,

Highlighted
Level 1c

https://imgur.com/a/mq8zcmX

 

Hey mate, i'm well aware the office network speed is higher. But point i'm trying to make is that you said that it was a problem outside the TPG network. However downloading it from 2 different connections i'm able to get much faster download speeds so it's not from Nvidia's servers that's bottlenecking me.

Having a 92mbps line and getting 200kb/s is surely a routing issue. When i swap to telstra 4g i think i only get 30-50mbps speed test and get about 5mb/s. I'll take a screenshot of those results when i get home later.

 

Highlighted
Moderator

Hi @Coldplayer,

 

Thank you ! Please also run a Tracert on your laptop connected to your mobile hot spot for additional reference. We'll wait for the result.

 

Cheers!

 

Highlighted
Level 1b

@Coldplayer wrote:

https://imgur.com/a/mq8zcmX

 

Hey mate, i'm well aware the office network speed is higher. But point i'm trying to make is that you said that it was a problem outside the TPG network. However downloading it from 2 different connections i'm able to get much faster download speeds so it's not from Nvidia's servers that's bottlenecking me.

Having a 92mbps line and getting 200kb/s is surely a routing issue. When i swap to telstra 4g i think i only get 30-50mbps speed test and get about 5mb/s. I'll take a screenshot of those results when i get home later.

 


100% is a routing issue, this seems to happen with Internode as well, figured it was because Internode/iiNet was acquired by TPG some time ago, but i have the exact same issue as you, it works perfectly fine when using nordeVPN, i get my full 100 down, theres a post on the blizzard forums saying the same thing https://us.forums.blizzard.com/en/blizzard/t/modern-warfare-slow-download/1584 I guess we will just have to keep using a VPN to get our max download speed...