TPG Community

Ask, answer and talk about our products

Disabled WiFi on modem but can't get it back

SOLVED Go to solution
Level 3

Hello,

I turned off the Enabled checkbox on my Huawei-532d modem under Basic->WAN to disable WiFi, but after re-enabling it with an ethernet cable connection, the WiFi no longer shows up under Windows. A bunch of neighbouring ones do, but not mine. It was working perfectly well before. Under Basic->WAN, "WAN connection" Enabled is checked, and under Basic->WLAN, WLAN tab, Wireless Enabled is checked. The Wireless light on the modem is on. I had previously changed my modem's admin password, but that's working. It lets me in with the new password and I can look at all the tabs and options. I doubt anything's broken. It's working with a cable. There has to be a setting not right somewhere, but where?

12 REPLIES
Level 6

Hi @solar1714 make sure the SSID box is ticked and try unticking the WPS box, also make sure the wireless mode is b/g/n, make sure you click submit to save and then reboot the router and the device your trying to connect, see how that goes.

Level 3

SSID is enabled. I unticked WPS. On 'Submit' I got a message that the password was too simple (Don't know what password), but I went ahead. Mode is 802.11b/g/n. I rebooted the modem, but the WiFi still isn't showing up.

Level 6

So, can you see your routers WiFi on your other mobile devices? You should set the WLAN security mode on the router to WPA2-PSK, then the encryption type to AES and put in an 8 digit password at minimum, submit again etc, is this a windows 10 machine you're having trouble with?

Level 3

Windows 8. My Android phone doesn't see it either, but it used to, so it looks very much like a modem problem.

 

The Welcome Pack says to use WPA-PSK/WPA2-PSK and TKIP/AES, but either way it's not showing up.

 

Level 6

Can you post a screenshot of the WLAN setup page.

With regards to TKIP you would only enable that option to support a really old device, if any device does connect with that protocol it will throttle back to 802.11g speeds at 54 Mbps instead of the theoretical maximum 802.11n speed of 300 Mbps. Besides, it's not considered secure compared to AES only.

Level 3

I'm not at home now to try anything, but I did take some screen shots with me, plus all the logs. I got this soon after I re-enabled 'Wireless' but before trying changes (such as turning off WPS).

 

Modem_WLAN.png

Level 6

Thanks for that, I don't suppose you had already tried a full factory reset? It will mean you need to re-enter settings but may just do the trick if it's been corrupted somehow, give it a go when you get home, also check the WLAN filtering page to make sure your list of devices hasn't somehow been checked as blocked, good luck.

Level 3

No, a factory reset was going to be my last resort because I don't know what settings had been changed from default when TPG sent it. It worked out of the box without me having to do anything except enter passwords.

 

Level 6

As long as you know your TPG username and password you'll be fine.