TPG Community

Get online support

Port Forwarding on the TP Link VR 1600 V2

Crimthann
Level 2

Hey there, I am having some issues with forwarding ports with my TP-Link Archer VR1600v.
For context:

  • I am trying to run a minecraft server with a raspberry pi.
  • The pi has a dynamic ip linking to a cloudflare url which can be pinged successfully and the ip is successfully updating.
    • I have been trying both the url and the current public ip when testing the ports.
  • I have hopped onto the router and set up a virtual server in NAT Forwarding, with external and internal ports 25565 and internal ip pointing to my raspberry pi, using "TCP or UDP" (The All setting in the router)
  • I can locally connect to my minecraft server, I just can't use its public ip, so it seems to be a port forwarding issue.

I can't see why this is not forwarding the port. I have tried connecting with both the telnet command and an internet checker, both are coming back negative.

4 REPLIES 4
david64
Level 12

Hi @Crimthann . You should give the Pi a fixed local ip address so the forwarding rule is always correct.

Using your mobile data and browser, put your public ip address in address bar followed by    :25000     then enter. Since router has no rule for port 25000, it discards the request and your browser will eventually timeout; took too long to respond. 

Repeat using   :25565

What happens with this?

Add a rule for port 80 pointing to Pi. Won't matter that there is no web server. In your mobile browser, just put your public ip address and enter. Should come back straight away with "connection refused" since port is closed on Pi.

Do you have any other type of server you can run on Pi or another computer? Web server, SSL, FTP?

Crimthann
Level 2

Hi @david64.

I have set a fixed local ip for the pi.

Using 25565 resulted in the same timeout, and just using the public IP address without a port after entering the port forward rule is hanging without a timeout. Been going for about 10 minutes now.

I am unsure exactly what you mean by this last question, sorry. Trying to ssh into the external ip times out as well.

david64
Level 12

@Crimthann . Your rules for ssh and sftp are similar to the minecraft rule, including the interface name (ewan_pppoe), just different port numbers? 

Some time ago, TPG said they were blocking ports for some users with the lame excuse that there was suspicious activity against the VOIP function. Their suggestion was to use ports between 30000 and 40000. Are you able to setup minecraft in this way?

Are you familiar with any packet capture software, eg. Wireshark.

On my mobile Android Chrome, I get "refused to connect" if I browse to a port which has a rule but is closed on the computer.

Crimthann
Level 2

@david64, cheers for the help, mate.

Looks like the issue was the interface name. On the guide I was following, it was pppoe_8_35_1_d. Swapping it to ewan_pppoe has fixed it.