Security Protocol

Highlighted
Level 2

I have Mozilla Thunderbird version 78.4.0 installed.  With an update I found I could not receive emails.  A bit of searching found that the security.tls.version.min protocol was automatically set on 3.  I changed the 3 to 1 and it worked.  It seems from the Thunderbird 78 FAQ that TPG did not support the modern TLS 1.2 connection security protocol, and was/is using TLS 1.0 or TLS 1.1  If this is incorrect and TPG does support the later protocol, can I upgrade my TPG app/connection? 

6 REPLIES 6
Highlighted
Moderator

Hi @tmillard,

 

Thanks for raising this to us, we'll raise with our Engineering Team to clarify what TL version protocol is supported.

 

We'll provide you a feedback when update becomes available.


On the other hand, if you wish to upgrade your NBN Plan you may do it online.

 

See link below.

 

Changing NBN Plans through My Account

 

Regards,

 


 

 

Highlighted
Level 2

Thanks for your reply.  My main concern was having the app(?) upgraded to the newer protocol.

Highlighted
Moderator

Thanks for the clarification. This has been raised to our Engineering Team and currently awaiting for an update, we'll provide you a feedback when it becomes available.

 

 

Thanks for your reply.  My main concern was having the app(?) upgraded to the newer protocol.

Highlighted
Level 1b

Hi 

With the help of the TPG Community and not to mention a very helpful moderator. I managed  to change the settings in Thunderbird Current version 78.4.1.

       

The main cause of this issue is that the latest version of Thunderbird only allows TLS version 3 and 4 by default.

A better work around is to the default configuration and Thunderbird to use a lower Minimum Security TLS Version rather than using a none secured connection.

 

Here's how.

1. Go to Tools -> Option "might need to press on ALT to show the menu bar"

2. In Option go to Search bar and for security.tls.version.min

3. Change the value from 3 to 1 and press OK


NOTE:
There's a case that you may not be able to search the 'security.tls.version.min' directly.
You need to search 'security', then look for 'Config Editor', then accept the risk, then search for the 'security.tls.version.min'. Double click it in order to change it to '1'.

The Email should start working again.

Thank you again.

 

                         

Highlighted
Level 1b

I have changed the 'security.tls.version.min' to 1.

This has worked for allowing incomimg emails to be received with TLS active.

This has NOT fixed the issue with outgoing emails.

Any help or advice?

Thanks in advance.

 

Highlighted
Level 1b

I got outgoing emails to work by changing to PORT 465 not 25

Thanks