TPG Community

Ask, answer and talk about our products

Slow ADSL2+ speeds

Level 1b

Hi, over the last few weeks i have noticed my ADSL 2+ speeds have gotten even slower. I am waiting for basic websites with text and some pictures to load, and every youtube video is buffering unless i lower the resolution right down to 480p or below...

 

I did a speed test using and got 1.99 mbps download. 

 

I have cycled the modem and have tried switching from wifi by plugging in an ethernet cable directly into the computer but there is not much difference.

8 REPLIES
Moderator

Hi @theepan31,

 

Thanks for raising this matter to us and sorry to hear that you're having issues with the speed of your service. I would like to take this opportunity to help you and have this investigated.

 

I went ahead and searched for your account on my system using your community name, but I am unable to make a match. Can you please send us your TPG username or customer ID so we can run some test on your service and identify the possible cause of the slow connection and fix it.

 

Kind regards,

Mc

Level 1b

Hi thanks for the reply.

 

My TPG username is theeps31.

Full name on the account should be Kanathiban Kathirgamanathan

Moderator

Thanks @theepan31!  Please allow me some time to test your service, I'll be back shortly.

Moderator

We've managed to test your ADSL connection and I'm seeing a high capacitance on the line. This is usually caused by unfiltered devices. Can you please check if all of your telephony device(s) are properly filtered.

 

You can also try to isolate the modem or connect it straight to the wall socket without filter or other devices connected to the other telephone wall socket and observe again the connection.

 

Is it also possible for you to try a different modem to rule out your modem having a fault?

Level 1b

Hi thanks for your quick reply.

 

The only device I have plugged in to a wall socket (directly) is a netgear modem/router. We don't have a home phone or other telephony device.

 

I have tried another modem but I can't even establish an internet connection with that one - maybe it is faulty. I will see if I can find another one.

 

 

 

Moderator

Let me know how it goes, @theepan31. Keep in touch!

 

Mc

Level 1b

Hi,

 

I just splurged and have now installed the powerful ASUS AC68U modem/router.

Speeds are slightly better - but can you run the tests again to see what you come up with?

 

Regards,

Theepan

Moderator

Hi @theepan31,

 

I checked your service and the connection speed on the line is passing based on your distance from the exchange. If you wish to know the speed connection.

 

I recommend you to run a speed test on a desktop/laptop connected via Ethernet/LAN cable and run a test using Speedtest By Ookla.

 

Please post the test result on this thread.

 

Cheers!