TPG Community

Ask, answer and talk about our products

Slow NBN speeds

Highlighted
Level 1a

Hey team,

 

We've signed up for the NBN50 plan, and are currently getting speeds of 3-5mbps download. This is 10% of the 'typical evening speed'

 

It's really not good enough, considering I've had ADSL speeds quicker and cheaper. can someone tell me why the heck this is meant to be better? Is switching to another provider going to fix the problem?

 

TomScreen Shot 2018-09-16 at 10.09.27 pm.png

5 REPLIES 5
Moderator

Hi tompaterson2,

 

Welcome to the Community! 

 

I was able to locate an account using your Community details and ran remote tests. The test results were inconclusive and we have not found any evident line fault. 

 

Have you perhaps tried testing the speed via wired (LAN) connection? How many users are currently connected to the network simultaneously? 

 

I recommend having a read of this TPG Community article which can help us with the issue you're experiencing:

Troubleshooting a Slow Internet Connection 

 

Please let us know how it goes. 

 

 

Cheers! 

Level 1a

Hi unnamed fellow,


Thanks for your welcome.

 

I was able to conduct another speedtest somehow, with the speeds being so slow I wasn't sure the page would load.

 

Yes i have tried an ethernet connection, and at the time of testing only one device was active. Have you perhaps tried providing internet speeds that people are paying for?

 

I recommend, paying NBN co for enough bandwidth to service the customers in the area, and not making customers go through a list of BS questions to stall.

 

If the service does not improve, I will be switching providers and requestiing a full refund, going to the ombudman if required.

 

Sorry to be blunt

 

Kindest regards

Tom

Moderator

Hi @tompaterson2,

 

I would like to arrange a call from one of our Technicians for further test and investigation.

 

Kindly PM me your best contact number and preferred time tomorrow.

 

In case you need a reference:  How to send Private Message.

 

Regards,

Level 1a

Hi there,

 

Thanks for your response.

 

Upon further research my feeling is that the government is to blame. I have called tech support and they have escalated the issue to an engineer.

 

God help us if this is the best we can come up with.

 

Cheers

Tom

Moderator

I am glad to know that @tompaterson2.
 

Looking forward to have this issue fixed as early as possible.
 

Let us know how it will go and should you require further assistance.



 

Regards,