TPG Community

Ask, answer and talk about our products

TPG and ABC IView -

SOLVED Go to solution
Level 1a

I have a Sony Bravia TV which I have hooked up with the TPG provided internet service.  I mainly use this to watch shows on the ABC through ABC IView.


However, since our service was transferred from Telstra to TPG early last week, the programs on IView have not been updated and even though I have refreshed the internet connection on the TV, it has not solved the problem.  I have noticed that shows on Channel 10 are being updated to TenPlay since the date of transfer, so the problem seems only to be with ABC IView. I am having no trouble accessing Netflix through the TV, so the internet connection appears to be working.


Can you please advise how this problem can be resolved.

Level 3

As you indicated, internet connection to your Sony Bravia TV is working as you can stream videos from Netflix and TV catch-up service TenPlay is also working.


All I can think of is try checking that you are actually using TPG's DNS settings on your router and Sony Bravia TV. Do not use a VPN.


Also, check if the clock on your Sony Bravia TV is set correctly to your local timezone.


I hope this helps.

Level 1a

Thanks for that.  Turned off the VPN but it made no difference.  Can't understand why TenPlay is updating but not ABC IView.  This problem only started when I switched over from Telstra to TPG?????

I thought due to the government cutbacks to the abc they are going to discontinue iview?

Level 1a

iView is working OK for me via TPG on a Samsung Smart TV.
There is no logical reason that a different ISP would stop iView from refreshing, if you have a working Internet connection to the TV. I just checked the front page of iView on my computer and it is showing the same front page on the iView app on TV.

There are three things I recommend you try:

1. On my Samsung TV, there is a reset link in the Settings Menu, which will empty the Cache for all Apps running on the TV. After performing the reset, Apps that require a Login, will have to be logged into again. Doing this on a Samsung TV, has fixed a lot of problems with some apps - especially after an App Build update.

2. If iView is NOT an default app, try un-installing iView and then re-downloading a fresh copy.


3. In the Network Settings for your Sony TV, see if there is a setting for DNS Server.
If there is, change it to Google DNS Server address, which is the following:
Primary =
Secondary =

After you do any of the above, turn your TV off at the wall for 60 seconds and then turn back on.
Hopefully this will fix your problem.