TPG Community

Get online support

very slow speeds - slow ping

Level 2

Over the last few days I have been experiencing very slow ADSL internet speeds over wi-fi and when I hard wire into the modem on the laptop. I am getting 1,500ms ping times, which seems extraordinary for ADSL. Momentarily, things resolve themselves and I go back to a 24ms ping time and 12-14mbps download speeds. It's really frustrating, but most of the time the internet is so slow its unusable at around 1-3mbps download. Is there an issue at the Waverley exchange or in the queens park area?


Hi @joedennis,


Welcome to TPG Community!


I was able to locate your account using your community details and have run some remote test. I'm not able to detect any issues with the copper network.


However, I've seen an evident high data upload happening in your service. The upload sync for ADSL service is up to 1 Mbps only. If a device is consuming the Upload bandwidth, then it will affect the browsing/streaming on your devices due to the traffic.


Simply imagine a 2 way road which can only fit a regular car. 1 lane for Download, and the other is for Upload. Normal activity will not affect the traffic on the road, but once there is a Big truck (Upload which consumes the 1 Mbps bandwidth) who occupies the 2 lanes, the cars (normal website that you've entered to a different device or same device) behind it will not be able to pass until the truck reaches its destination.


For accessing website or apps, once you have entered an address on your browser and hit enter, it is already considered as Upload since it will go up to the internet cloud/server, then the reply of the server/cloud which includes the information, page pictures, etc. is considered as Download since the data are going down to your device.


You may try to limit the data that you are uploading to make room for your devices to browse the internet at the same time.


If you are not uploading, then you need to check the auto backup files on your devices. If it's enabled, then you need to set it manually instead for you to control the bandwidth that is being used.


Kind regards,