TPG Community

Get online support

Archer VR1600v iOS devices wifi connected but no internet

Level 2
Connected my Archer VR1600v nbn modem today. Laptop works fine. Samsung mobile works file. iOS devices connect to wifi but no internet. 1.5 hours on phone with help desk and still not working. Have reset router, have reset network settings on iOS devices, have powered down iOS devices and tried again. Nothing is working. Any suggestions?
Level 8

Hi @Adele I see that you've already reset network settings,  can you also check that you have Personal Hotspot turned 'Off'. Which model iOS device/s are you having issues with?

Level 2

I have had a similar problem with an Android Sony TV.

My setup:
NBN Technology: NBN Hybrid Fibre Coaxial (HFC)
Plan:  NBN Cable 50
NBN modem: ARRIS Model CM8200B
tp-link modem/router:
Hardware Version:  Archer VR1600v v2 00000000
Firmware Version:  010091 v5006 0 Build 190228 Rel 72265n
Computer:  Dell Optiplex 9010
OS: Windows 10 Pro Version 1809 Build 17763.529
Default Gateway:
DHCP Server:
DNS Servers:
DOS Protection:  Enabled
Access Control:  On
Access Mode:  Whitelist
Devices in Whitelist: List of connected MAC addresses
     android smart TV
        Sony  Bravia KD-55X9000F
         Kernel version 3.10.79 root@BuildHost597 #1
        BuildBRAVIA_ATV3_4K_PA-user 7.0 NRD91N.S139
I had trouble with getting an internet connection from the TV.
There was no problem with the PC, iPhone and iPad.
The TV would connect to the VR1600v via 2.4 wireless, 5G wireless and LAN cable, but would not get an internet connection. The wireless connections were setup by manually selecting the networks to join.
The TV would report that a wireless connection was made but that it could not connect to the internet. The was confirmed by navigating to the Network Status page from the TV settings page and performing a connection test. This showed:
     Wireless device on TV: found
     Local access:  {Ipv4: OK][IPv6:Failed]
     Internet access: [IPv4:Failed][IPv6:Failed]
The Network status page showed Good for 2.4 and Fair for 5G.
I had a similar problem setting up the TV with the ADSL2+ Huawei HG532d WiFi but was able to resolve the problem by setting the DNS servers IP addresses as listed above.
With the VR1600v, setting the DNS IP addresses did not help.
My thought  was that something in the VR1600v was preventing the TV device from getting the internet connection. Also that it must be a problem with the TVs implementation of the protocol since that other devices connected successfully.
One thing to try was to remove the Access Control Whitelist specifications.
To do this I used the web interface for the VR1600v to reset to the factory defaults, which also rebooted the VR1600v. I then re-entered the device settings that I wanted, but omitting the whitelist - just leaving a blank Blacklist.
Retesting the TV WiFi connection gave an internet connection for IPv4 straight away.
So it seems that the problem is caused by the interaction of the VR1600v Whitelist system and the Sony Android TV protocol handing.