TPG Community

Ask, answer and talk about our products

Connecting Google Wifi to the Huawei HG659 Bridge Mode

SOLVED Go to solution
Level 1a

Hi guys,

I've just purchased a Google Wifi and I'm having a few issues with some of my services, mainly PLEX. I've connected the Google WiFi to the HG659 which gets internet just fine, but I cannot access the PLEX outside the home network along with a few other issues. It all has to do with having two routers.

Double NAT seems to be the problem but I cannot set the HG659 to Bridge Mode and the Google WiFi won't let me do it either.

Is there a way to set the HG659 to bridge mode?

10 REPLIES
Staff

Refer to this TPG Support document:

Huawei HG659 Modem Configuration Guide

 

Proceed to page 3 of the PDF document.

 

Once you have logged in to the modem, click on Start Wizard.

 

By-pass instruction to enter your username and password and select the fourth option: Connect with another modem.

 

Click next and follow the succeeding instructions.

 

This will allow you to set up Huawei HG659 in bridged mode.


* * * *
Have you seen a helpful comment lately? Be sure to give it a Like.
If a reply to your question solves the problem, be sure to mark it as an Accepted Solution.
* * * *
Moderator

Good day @theNotic,

 

Welcome to TPG Community!

 

In regards to " but I cannot access the PLEX outside the home network along with a few other issues. It all has to do with having two routers. "

 

Does your device (Mobile/Computer) is not connected to your Home wifi and you are trying to access PLEX remotely? If it is, did you enable the remote access feature on your HG659 and Google WiFi?

 

You don't need to set the HG659 into bridge mode, since your Google WiFi is just a router and not a modem. Unless it is a different model compare to what I've seen? Are you able to provide us the model of your Google WiFi?

 

If you are on NBN FTTN/HFC/FTTB, when you bridge the HG659, the phone feature will not work anymore.

 

Please provide us more information about your set up for us to visualize it further.

 

Kind regards,

Level 3

Hi

 

If I bridge my Huawei HG659  Won't it then disable all the ethernet ports and the Phone line?

 

The only other option I can see is to add the google wifi as another LAN port though will there be double hopping with that solution?

 

Regards

Andrew

Moderator

Hi @dowdie,

 

Welcome to the community!

 

Yes, if you set Huawei HG659 on bridge mode. Ethernet and VoIP port wil be disabled.

If you wish to use a 3rd party router/google Wi-Fi you can simply turn-off/disable Huawei HG659's Wi-Fi and connect the google Wi-Fi.


I searched a setup guidelines for Google Wi-Fi please see below.

 

  1. Connect the provided Ethernet cable to the WAN port [] of your Google Wifi point. Then connect the other end to your modem.
  2. Plug your Google Wifi point into a power outlet. The light will slowly flash blue to indicate that it’s powered on and ready for setup.
  3. Place the Wifi point in plain view -- you’ll get the best signal when it’s in an open space like on a shelf or TV stand.

Credits to Google Support to see complete details you can visit this link.

 

Let me know should you require further assistance.

 

Regards,

Level 3

Thanks for the great support it's been working well although now I have new issue.

 

I've installed a rpi3 and assigned a reserved IP address within google wifi for it, the problem is whenever the PI reboots it gets another IP address and ignores the reserved IP.  I figure this is because there are now two DHCP servers running. (google + huwahei)  I tried disabling DHCP in the huwahei router but then I lost all internet.  Any ideas of how DHCP from the huwahei HG659 router can be either disabled another way or ignored?

Staff

Hi @dowdie

 

If your Raspberry Pi 3 computer ignores its reserved IP address in Google WiFi, then it could be that:

  • the Wi-Fi on your Huawei HG659 modem/router is enabled, and;
  • the two devices (Huawei HG659 and Google Wifi) are using the same W-Fi network name (SSID).

Since you have already reserved an IP address for the Raspberry Pi 3 computer in Google WiFi, all that is left to do now is to disable the Wi-Fi on your Huawei HG659 modem/router.

Quick Tip: If the WLAN LED light on the Huawei HG659 is green, then its Wi-Fi is enabled.

Guide on how to disable Wi-Fi on Huawei HG659:

 

  1. Connect a computer directly to the Huawei HG659 with an Ethernet cable.
  2. Open a web browser and in the address bar type 192.168.1.1 and press Enter.
  3. Enter admin for both the username and password, and click Login.
    (If you have changed the login credentials, please enter the current username and password for your Huawei HG659).
  4. Once on the Home page, go to Home Network > WLAN Settings > Basic Settings
  5. Remove the tick on Enable WLAN 2.4 GHz
  6. Remove the tick on Enable WLAN 5 GHz
  7. Click on Save button, then click on Log out.

 

Disabling the Wi-Fi on your Huawei HG659 should now result in your Raspberry Pi 3 automatically connecting to Google Wifi and adapting its assigned IP address.


* * * *
Have you seen a helpful comment lately? Be sure to give it a Like.
If a reply to your question solves the problem, be sure to mark it as an Accepted Solution.
* * * *
Level 3

Hi JongR

This issue happens even with the huwahei routers wifi disabled. That's the first thing I did when I set up Google WiFi a few months back.

I tried disabling dhcp on the huwahei router also but that dropped my internet completely and I had to reset the huwahei.

If I could I'd bridge the huwahei router i would but I'll lose my phone

Could it be anything else?

Regards
Andrew
Staff

Hi @dowdie

 

You said that the problem was that whenever the Raspberry Pi 3 reboots it gets another IP address and ignores the reserved IP.

 

Could you please try to go through the process of re-assigning a static IP to Raspberry Pi 3?

  • remove Raspberry Pi 3 from Google Wifi's list of devices with assigned IP addresses;
  • connect it again to Google Wifi, then;
  • reassign a static IP to it.

 

I found the following guide in Google Wifi help:

 

1. Open the Google Wifi app.
2. Tap the upper right tab, then Network & general.
3. Under the ‘Network’ section, tap Advanced networking.
4. Tap DHCP IP Reservations.
5. Press the add button in the lower-right corner.
6. Choose the device for which you’d like to assign a static IP (in this case, the Raspberry Pi 3).
7. Tap the text field and enter an unused static IP address, then Save.

Note: You may need to disconnect Raspberry Pi 3 from your Google Wi-Fi network and reconnect it before it is assigned the reserved IP.

 

Let's see if this works.


* * * *
Have you seen a helpful comment lately? Be sure to give it a Like.
If a reply to your question solves the problem, be sure to mark it as an Accepted Solution.
* * * *
Level 3
Thanks for your help I'll give that a shot. On holidays at the moment so won't be able to do that for a few days

Cheers
Andrew