TPG Community

Get online support

Disable IPV6 on modem?

Level 2

HI Team

After some working through with the tech team from Disney, it appears that my new SAGEMCOM FAST 5866T needs to have IPV6 disabled in order to stream Disney Plus - I can see on the device management screens that some devices get IPV4 adn some get IPv6 addresses, how do I disable the IPV6? There does not appear to be a setting I can access to do this.


Hi @rudym


Thanks for raising this with us.


May we know the make and model of your modem/router? Also, please send me a PM with your TPG username or customer ID number to assist you accordingly.



Level 2

I am having similar issue with SagemCom F@st 5866t; I have already raised a ticket but haven't gotten any solution. 

My issue

1. When I try to cast or mirror videos or photos from my iPhone or Android phone, I don't see any devices in the network. However, I have three google cast receiving devices(nest and a hub) and one TV with built-in Chromecast and Airplay/Homekit service.


I already tried contacting TPG Support. It seems nobody has the answer to this.

I did some research and found out ipV6 is the issue, as I am getting 3-4 IP V6 addresses and an ipv4 address.


I came to this conclusion after taking a long list of troubleshooting myself that involved.

1. Turning off Band Steering, 

2. Isolating 2.4GHz and 5GHz signals naming them separately.

3. turning of WMM and 5GHz.

4. Resetting modem 3-4 times


I turned off all the wireless signals (2.4GHz & 5GHz) and added a second router (disabled ipV6), which also has 2.4 and 5 GHz; it worked perfectly fine. 


I am still waiting for someone to fix the issue. It's been almost a week+




Level 3

There's definitely something wrong with either the Sagemcom IPv6 implementation, or the IPv6 configuration of the service itself. Disabling IPv6 on Windows machines speeds up DNS resolution immensly and stops the occassional DNS lookup timeouts.


I noticed in the Sagemcom that the upstream DHCP server is giving the router an IPv4 DNS server address, for the IPv6 DNS forwarders. And the DNS portion of the test fails the IPv6 DNS tests too.


It's a shame this great service (as far as the 5G carrier is concerned) is being hobbled by technical issues related to IPv6 and the Sagemcom bugs itself. I wouldn't mind a firmware update to the latest that TPG has for this router, to see if it's fixing any of these issues. it seems impossible to get.

Level 2
Level 2

To TPG Support,


Please provide a firmware update that includes the option to disable IPv6 in the user interface. There have been numerous discussions about this issue. Certain Android apps, such as Strava, Life360, and Microsoft Authenticator, work perfectly on mobile data but become significantly slower when connected to WiFi, specifically on home networks. I've observed this behavior consistently with both Samsung S22 and S24 devices using the SAGEMCOM FAST 5866T router.


We're gradually gaining insight into the root cause of this issue. Disabling IPv6 can sometimes improve the performance of apps like Strava and others. While I don't have all the technical details, my understanding is that IPv6 isn't universally supported across the entire Internet infrastructure. Given that TPG (Vodafone ISP) doesn't support IPv6, allowing end-users to disable it in the UI seems like a reasonable solution. The use of IPv6 might necessitate additional translations and lookups, which could be contributing to the observed slowness.


You can verify IPv6 connectivity using the following link:


Below are the results I obtained when running this test from my WiFi home network, which indicates that IPv6 is not supported:

Level 3

Hi knt


Yes it's not just slowness that occurs when the 5G route is handing out public IPv6 addresses, some things just plainly don't work at all. GMail fails to send, Google Drive fails to sync, Google Play content fails to load on Android TV, BOM App fails to load its content on Android phone, Podcasts fail to download on Pocketcasts. All solved as soon as you stop IPv6 routing.

Level 2
I stumbled across your post by chance while googling a similar issue.

I'm a Vodafone 5G wireless customer and have started having the issues you are describing. I've had the service for 2 weeks and the issues only started a couple of days ago.

My google nest speaker no longer accepts voice commands.

My S20 has issues with the same apps you are saying, Strava, Weather a few others etc.

I flick to mobile data and everything is OK.

Though I don't understand the technical side of the issue just wanted to chime in and say something is definitely going on from my experience as well.