TPG Community

Ask, answer and talk about our products

Network Printer not showing on Archer C1200

Level 1b

I have an Archer C1200 that I am plugging a printer into via an ethernet port and it does not show up on the network.  Same also appears to be true of both my TVs. Laptop is fine.

Am I missing something or does the Archer just not support printers etc?

5 REPLIES 5
Highlighted
Level 8

Hi @danewman Check this compatibility list to see if your printer is supported, https://static.tp-link.com/resources/compatible/Print-Server/Print_Server_Compatibility_List_160804.... . Let us know what you find.

Level 1b

Thanks Orbistat

Neither of my printers are showing on the list, it seems to cover cheaper printers only.

It is a case of replacing the Archer with something better?  Can i even do that?

Level 8

Hi @danewman what model is your main networked printer? Have you tried assigning a static IP oustside of the routers DHCP range 192.168.100 - 192.168.1.199 ? I usually set my networked printer to a static 192.168.1.250

Level 1b

The one i really need to get working because it is shared is a Brother HL-4150CDN, secondary because it is only used from my PC and could be done directly via USB is an Epsom Stylus Pro 3800.

Both fairly old but decent and expensive printers.

Appreciate any ideas, cant get at the settings on the Brother it does accept DHCP based on the fact it worked before we moved house on a Telstra router.

Level 8

Hi @danewman you could try connecting the printer via a USB cable rather than Ethernet cable to the rear of the C1200 which I beleive has a print server capability, then use the connect printer wizard on a PC to find the networked printer and see if that works, it may prompt you to install an updated driver.