TPG Community

Get online support

Static routing error 5108

SOLVED Go to solution
forumuser67
Level 2

Hello,

 

I am trying to set up static routing using the Archer vr1600r using TPG FTTB.  For context, the purpose is to avoid connecting to overseas servers while using an Xbox using this guide:  https://www.reddit.com/r/halo/comments/r02gkf/bug_fix_no_more_lag_select_the_server_you_want_to/ 

 

When I try to set up the static routing, I receive Error Code 5108 "Gateway must be on the same subnet with the device interface's IP address. Please input another one." 

 

As an example, I've tried these details and get the error:

Network Destination: 102.133.196.95

Subnet: 255.255.255.0

Gateway: 192.168.1.1

WAN interface pppoe_ptm_2_0_d

 

I'll note that the default gateway is set to 10.20.26.36, so I'm not sure if that is contributing to the error eg if the default gateway needs to change?

 

Any assistance would be much appreciated!

 

Cheers

1 ACCEPTED SOLUTION

Accepted Solutions
david64
Level 12

Hi @forumuser67 . When you play games on the Xbox, can't you specify which game server you want to use? Or, does the game detect which server has the best response time?

Have you read the VR1600 user guide on static routing? 

For your purpose, you need to create a route for each of the addresses in "Metric 2" in that article that you don't want to use. The route directs the server ip address to a dead end.

Eg. if you don't want to use southafricanorth, the settings are:

destination: 102.133.196.95

subnet: 255.255.255.255    

gateway: 192.168.1.2     (imaginary router)

interface: LAN    

To avoid another server, make another route with same subnet, gateway and interface. If you can only have one ip address per gateway, assign the next value up.

There might be a delay while the game detects that it can't reach the servers in the defined routes.

 

View solution in original post

9 REPLIES 9
david64
Level 12

Hi @forumuser67 . When you play games on the Xbox, can't you specify which game server you want to use? Or, does the game detect which server has the best response time?

Have you read the VR1600 user guide on static routing? 

For your purpose, you need to create a route for each of the addresses in "Metric 2" in that article that you don't want to use. The route directs the server ip address to a dead end.

Eg. if you don't want to use southafricanorth, the settings are:

destination: 102.133.196.95

subnet: 255.255.255.255    

gateway: 192.168.1.2     (imaginary router)

interface: LAN    

To avoid another server, make another route with same subnet, gateway and interface. If you can only have one ip address per gateway, assign the next value up.

There might be a delay while the game detects that it can't reach the servers in the defined routes.

 

View solution in original post

forumuser67
Level 2

Hi David

 

Thanks very much for your reply, the help is much appreciated.  Unfortunately you can't specify which server/region you want to use on certain games - the game selects the server, which often leads to the US West servers with 200+ ping. I have read the manual for the VR1600 for static routing here: https://static.tp-link.com/res/down/doc/Archer_VR600v(DE)_V1_UG.pdf

 

Static routing seems like a straightforward process in the manual (and it probably is for someone with more technical acumen than I...).  I have tried following the manual, but get the 5108 error code, seemingly when trying to use my router's IP address of 192.168.1.1 (as recommended in that reddit article). 

 

I have also tried using your recommended settings. When I do this, the error does not appear.  However, I don't think the static routing is in effect with those settings as I am still getting put onto servers with 200+ ping. 

 

Can I ask:

- the manual refers to a second router ("Router 2"), but this may be for the example it uses only. I assume there is no need for a second router?  (My current set up is just the VR1600 connected to the wall, and I'm accessing the internet via wifi)

- you recommended selecting the "LAN" interface.  The tp-link router settings page notes when selecting the interface: "Select LAN or a WAN interface in the Interface field to specify the type of the Network Destination."  The network destination (ie servers I am trying to block) are not on my local network, so should this be a WAN interface instead?  (Of course, when I try a WAN interface, I get the error 5108 when trying to use my router's IP address of 192.168.1.1.)

 

Thanks again.

Cheers

david64
Level 12

@forumuser67 . In the manual, the example refers to some-one accessing their company's server using a dedicated link, via router 2. For your purpose, my understanding is there is no need for router 2.

The WAN option might be for a different purpose or network configuration. 

If you can run commands on the Xbox or if you have a computer, try this.

It looks like those servers don't respond to pings but you can do a tracert. Do a tracert to a server that doesn't have a route defined, ie. one you want to use. There will be some number of addresses but it may not reach the end. Add a route for this address and do the tracert again. It will fail. (Just tried this on mine.)

Ask other gamers with other providers to do tracert to these game servers. Slow response could be caused by bad routing with TPG. 

forumuser67
Level 2

Thanks David. I did the tracert to a couple of the servers and they succeeded.  If I end up getting this working, I'll post the fix here. Cheers again for your help.

david64
Level 12

@forumuser67 . Are you saying that tracert is unchanged after adding a static route?

 

Here is one that I tried.

tracert 13.75.49.198

Tracing route to 13.75.49.198 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms ARCHER_VR1600V [192.168.1.1]
2 5 ms 4 ms 4 ms 10.xx.xx.xx (router's default gateway)
3 5 ms 5 ms 5 ms 203-221-3-82.tpgi.com.au [203.221.3.82]
4 6 ms 10 ms 5 ms ier01.syd.ntwk.msn.net [104.44.37.149]
5 5 ms 5 ms 5 ms ae22-0.icr01.syd23.ntwk.msn.net [104.44.235.246]
6 120 ms 121 ms 120 ms be-100-0.ibr01.syd23.ntwk.msn.net [104.44.11.103]
7 120 ms 121 ms 120 ms be-15-0.ibr01.hkg31.ntwk.msn.net [104.44.7.195]
8 121 ms 120 ms 119 ms ae102-0.icr02.hkg31.ntwk.msn.net [104.44.11.120]
9 * * * Request timed out.
10 * * * Request timed out.

(didn't get through to the server)

 

Added a static route to router.

 

tracert -d 13.75.49.198

Tracing route to 13.75.49.198 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms 192.168.1.1
2 192.168.1.1 reports: Destination host unreachable.

Trace complete.

 

forumuser67
Level 2

That's right - the tracert is unchanged after adding a static route.

 

I traced to the same IP you have used - 13.75.49.198 - and got:

traceroute to 13.75.49.198 (13.75.49.198), 64 hops max, 52 byte packets

 1  192-168-1-1 (192.168.1.1)  3.831 ms  5.677 ms  4.777 ms

 2  192-168-1-1 (192.168.1.1)  3047.694 ms !H  3065.180 ms !H  3072.441 ms !H

 

Then added the static route using these details:

Select WAN Interface: pppoe_ptm_2_0_d (must select a WAN interface, and this appears to be the default)

Network destination: 13.75.49.198

Subnet: 255.255.255.255 (I also tried ending in 0)

Gateway: 192.168.1.2 (I also tried ending in 1)

Interface: LAN

 

Tracert result after the route was added: 

traceroute to 13.75.49.198 (13.75.49.198), 64 hops max, 52 byte packets

 1  192-168-1-1 (192.168.1.1)  5.046 ms  2.051 ms  3.577 ms

 2  192-168-1-1 (192.168.1.1)  3098.862 ms !H  3086.989 ms !H  3008.787 ms !H

 

So it appears the route isn't working.

 

Cheers

david64
Level 12

@forumuser67 . There's something wrong with both your tracert displays. The first one should display 8 hops followed by timeouts. The response time to router is slow (should be 1 ms). Does the Xbox use wifi?

 

The Select WAN Interface is correct. It is the default interface used to access the internet.

Gateway must end in 2 because it can't be 1 (which is the VR1600). I chose "2" the same as the example. But there can't be a real device ending in "2". What is the ip address of the Xbox?

Any address reservations?

Is the DHCP dynamic range still 100 to 199?

 

Can you delete all routes, do the tracert, then add a route for this ip address.

forumuser67
Level 2
Thanks David. The routing is now working. The Gateway I’ve used is the router (ie ending in 1). Having spoken with others, they agree that ending the gateway with 2 (or another number) would work. Thanks again for your help. Your recommendation to switch the interface to LAN was the suggestion which fixed the 5108 error and got the routing to work.
JackRussel
Level 2

I agree that the article on reddit does not describe everything unambiguously. This article, which is in the first post of this thread: https://www.reddit.com/r/halo/comments/r02gkf/bug_fix_no_more_lag_select_the_server_you_want_to/
However, after reading the explanations in this (current) thread, I understood my mistakes as well, thank you!