TPG Community

Get online support

VX220-G2V Wi-Fi Unable to connect

Level 2



I’m having an issue with my VX220-G2v router with the Wi-Fi randomly failing and I usually end up powering off the router and powering it back on again. And having a look through, the forums looks like I might not be the only person:


Issue appears to be with the 5Ghz only (most of my devices are 5Ghz). The devices affected appear to be random. Sometimes it’s a laptop, other times it’s a Chromecast sometimes it’s a phone. It only seems to affect devices that disconnect and have to reconnect. Devices that remain permanently connected to the Wi-Fi are fine. If I disabled the Wi-Fi on a working device while this issue was occuring, the device that was working also becomes unable to connect to the network properly.


When the issue happens, the device will be connected to the router / Wi-Fi network, it receives an IP address, DNS, etc, but is unable to contact anything on the local network or the Internet. I tested this by also giving a static IP address and the same behaviour of not being able to connect to anything. I can't Ping anything either.


I’ve tried turning off Band steering and having just 5ghz enabled, this actually helped slightly in that the issue appears less frequently, but probably still happens twice a week. This also increased the Wi-Fi range with this router as I only seem to be able to get about 10 or 15 meters before I start seeing drop outs.


Steps I’ve tried:

Setting encryption from WPA3 to 2

Setting Static IPs on devices

Resetting the router

Turning off band steering

Tried manually setting the Wi-Fi channel rather than using auto

Having just 5Ghz enabled on the router and disabling 2Ghz


Firmware on the device:

Firmware Version:2.0.0 0.9 v603c.0 Build 220517 Rel.49186n

Hardware Version:VX220-G2v v2.0 00000000


This device is still relatively new, we moved in Jan and this was the replacement device for our VR1600v which we didn't have these issues with.


Any ideas?


Hi @djmulls888 


We'd like to check on this further.


Kindly send us a private message with your account details.



Level 3

I have the exact same issue everyone else is experiencing. My Archer 1600 was fine.

I have to change a 5ghz setting like band to get internet working on 5ghz again. The SSID is connectable but no internet. Signal strength is fine and I'm next to the router.


I called TPG to report this as it is a brand new router that you made me go onto a 6 month contract and pay $10 for but I am going to have to go back to the Archer until I purchase myself a router that works properly.

The agent on the phone said they didn't know about this and would escalate. I advised this has been happening for years to other people. Same exact issue and they were forced to go back to old archer or new router.


I have collated all the posts i could find and the issue has been happening since at least 2022:

(1) VX220-gv2 Wifi Drop - Page 2 - TPG Community

VX220-G2 5ghz wifi band unstable - TPG (

Level 2

I have been speaking to TPG support for a little while now.


Initial conversation they said they would send a new device out. I received the exact same VX220 modem. I thought OK, maybe its just my one thats dodgy, I will give it a go. Nope, 6 days later the same issue again.


Speak to TPG again, and things didn't go so welll. Was advised to:

1) Contact TP-Link support to see if they are aware of the issue and see if I can get them to provide a fix???

2) Buy a new device


I did enquire whether there were other devices that TPG stock, got told the VX420 is an older device than the VX220 and that the VX220 is the device they are providing new customers.