TPG Community

Get online support

Can’t connect Google nest router w/ FTTB

chrisandgrace45
Level 2

Hi, I am having trouble connecting my Google Nest Router to the internet. I have FTTB NBN.

The modem/router supplied by TPG is the TP Link VX420-G2v.

To bypass the existing router function, I have tried setting up bridge mode for the TP link router with the following steps:

  • Going into network settings
  • Deleting the PPPoE network
  • Creating a new one with “Bridge”

When I do so, it seems that the internet doesn’t connect (modem light for internet is blacked out), and as such, I'm unable to set up my Google Router using the Google Home app.

Can anyone help me get the internet to work in bridge mode without losing internet connection? Or if you have any other suggestions, I'm all ears.


Thank you,

Chris

3 REPLIES 3
david64
Level 13

Hi @chrisandgrace45 . If you are on bundled NBN/VOIP plan (even though you might not use the phone), you have to add VLAN ID=2 when you set up the Bridge connection on VX.

If you are on BYO router data only plan, VLAN ID is not used.

The interface to delete is the pppoe_ptm.

Once in bridge mode, the Internet light on VX may stay off. You might not be able to access the admin either.

The Google runs in standard mode.

chrisandgrace45
Level 2
Hi David,

Thanks for your answer. I’ve tried what you have suggested - as I’m on a bundled plan, I deleted PPPOE_ptm and created bridge network with VLANid=2.

The internet light remains off. I then plugged in my Google router into Lan1 of the VX420, and the light on the Google router slow flashes yellow (network issue). As such, I’m unable to detect the device in Google Home app to set up the mesh network.

It seems there is no internet flowing through the modem when on bridge mode.

Questions:

- should the internet light be active when in bridge mode if i have correctly configured the VX to act as a modem and not a modem/router? If so, why isn’t mine on?
- is there anything I’m doing wrong to set up bridge mode?

I appreciate your help on this one.

Chris
david64
Level 13

@chrisandgrace45 . The App should connect to Google using its wifi, even without internet connection.

I expect the VX Internet light to stay off because VX is not logging on to TPG. You might check whether the VX wifi disappears when bridged.

Have a look at this. This user has FTTN which is same connection as FTTB. The instructions are for VR1600 but seem similar. And the settings to use on Google.

https://community.tpg.com.au/t5/Modems-and-Devices/Using-my-own-router-with-a-TPG-supplied-modem-rou...