TPG Community

Get online support

D-Link Cobra DSL-5300 FTTN Config issues

Level 2
Hi All,
I've scoured this forum and others, found many people with identical symptoms to me but none of their solutions have worked for me.
As the heading suggests, I've got a new Cobra 5300 modem/router and I cannot get it working with TPG at all. I can set it up as a router hanging off the old TP Link modem and it works fine but I didn't fork out good money for a high end modem/router to just use it as a router.
I've almost tried every conceivable configuration, I've spent 2 hours on the phone to two different tech support guys at TPG as well as an hour on the phone to D-Link. Still no closer. D-Link assume it's an authentication error but TPG claim the credentials I am using are correct.
I can get the DSL light up, I can't get the internet light to stop blinking. On the home screen of the D-Link user interface it says cable connected but network status is disconnected.
Level 15

Hi Woodsy321.

Have you read the manual?

What settings have you tried?


Set WAN access type to VDSL router and enable tagged vlan.

The settings are PPPoE, TPG username with on the end, password, and VLAN ID=2.

You can check the username and password by logging in to Post Office on your mobile phone.

For VLAN ID, set Internet VLAN ID=2 in Triple-Play section. 

In interface traffic type section, set each lan port, wireless and wireless guest zone to Internet.

Level 2
Yes, tried all of that. After the 4th hour on the phone and the 2nd call to D-Link with the 2nd technician, I have been advised to send the modem back. D-Link now believe it's faulty. This would make sense because when I opened the box it was missing the DSL filter/splitter, someone has already had this problem most likely, returned it to the store who have proceeded to re-sell it to me.
I will arrange the return and post back here with an update when I get a new one to try.
Thank you.