TPG Community

Get online support

Slow Internet - TPG App test vs

Level 2

We've got a new nbn installation that has been pretty flakey since day one. When I run a speed test using the TPG Mobile app I'm getting full 50mbs speeds as the "results". However, on the same device when I run the (app) test I'm getting 3-15mbs consistently.


This is more closely representative of the experience as general web browsing times out, Netflix won't stream or goes into a severely degraded mode. FTPing to and from web hosting times out.


Steps to remediate take that have had no effect:

- isolation testing

- using different routers (asus rtac87u, netcomm nf18acv, TPLink Supplied by TPG)

- connecting a single device to the network


I haven't yet run a pingplot but will and add the results to this thread tonight.


Has anyone else experienced a disparity in what the TPG App tells you and the actual speeds experienced? 


Hi @elodesignco,


You may check out this article which may help with your concern: Slow speed issue


If you are using a Wi-Fi connection, signal interference can play a part. We've created some articles that will help you improve your home network.

If you have performed all the troubleshooting steps indicated on the links above and still encounter issues, please send us a private message with your TPG customer ID, username and complete address so we can assist you further.


To send a PM, please refer to this link: How do I private message (PM) in the community