TPG Community

Ask, answer and talk about our products

Smart TV not connecting to wifi

Highlighted
Level 3
Level 3
Brand new Samsung smart tv can detect TPG nbn wifi but can’t connect to it.
However it can connect quickly to my telstra and Optus hotspot, so Samsung says it’s a TPG issue.

All my other devices (iPhone and iPad) in the home can connect to TPG wifi with no issue, so tpg is saying it’s a Samsung issue.

Hitting a brick wall.

Currently using a netcomm router provided by TPG.
Router separated from tv by one thin partition wall, approximately 10 meters away.

Suggestions to assist with diagnose/troubleshoot- a wifi booster, a 10 meters long Ethernet cable, a second non Samsung smart tv, or change internet provider (stuck in a 24month contract though).

Anybody having same issue?
48 REPLIES 48
Level 7

Hi @Tee What model Samsung TV and Netcomm router are you using? Could you post a screenshot of the current advanced WiFi settings page. I'm assuming you've already done a reboot of the router?

Level 3
Level 3
Thank you for your reply.
Router Model- Netcomm NF12
TV Model- Samsung 55 series 7 NU7100 UHD 4K

By reboot I have switched router power off and on, same for tv- to no avail.
Have tried changing router channels from 1 to 9.

Note it has worked on a couple of rare occasions when I do go into the router settings and just clicked ‘apply/save’ without making any changes, but the trick doesn’t work all the time.
Level 7

Hi @Tee thanks for the additional info, can you check that DHCP is enabled on the router, it will be in network/Lan settings or similar, the Samsung looks like it's reporting it's not being assigned an IP address, also make sure in the Samsung's settings it's set to be assigned an ip address automatically.

Level 3
Level 3
Level 7

Hi @Tee can you check which firmware version your Samsung TV is running by going to support in the menu, the latest version is 1152.8 if you're not on this version you should upgrade to it, as you can't connect to the internet with it you'll need to download the firmware file and extract it to a USB stick and select the upgrade via USB in the menu. Here's the download link https://www.samsung.com/au/support/model/UA55NU7100WXXY/#downloads

Level 3
Level 3
my current software version is currently 1152.8
Level 7

Connecting via your hotspot was my next suggestion but you’ve done that already! No need to USB update if it’s saying no update available, it would be interesting to see how an Ethernet connection will go but I’m guessing that’s not convenient to do?

Level 3
Level 3
I’ll have to look for a 10 meters Ethernet cable as tv is mounted. I got the tv for its wifi features so will source Ethernet cable for diagnostic purposes only.
What do you think it could mean if the Ethernet cable idea works or doesn’t work?

Level 7

Hi @Tee Yes if you can find an Ethernet cable for testing only it will help eliminate certain chipsets in the Samsung, the TV will have a WiFi module in it separate from the LAN chipset, what happens sometimes is that as new devices and hence new generation chipsets appear on the market, vendors need to update their hardware compatibility lists in their device firmware. There's a good chance either the Samsung is not on the Netcomm's list and vice versa.

I would be checking these things.

>Firmware is the latest version on the Netcomm router, you've already confirmed the Samsung is current.

>Confirm that the Netcomm is broadcasting in mixed mode 802.11 b/g/n. the F12 is a 2.4Ghz only model

>Check that the Samsung hasn't got a setting enabled that is only looking for a 5Ghz network.

>Temporarily disable encryption on the router by switching from WPA2 or WPA to NONE see if you can connect then.

>Try a factory reset on both the Samsung and the Netcomm but make sure you have your TPG login details available to enter into the Netcomm again.

Samsung support was incorrect saying it was a TPG issue, it's either a Samsung or Netcomm problem (or a combination of both) as the router runs Netcomm firmware not customised by the ISP

please report back how you go.