TPG Community

Get online support

SOS only ,No signal

Level 2

I have called TPG and kept me for 3 hours and could not go through.

Can someone please help why i have no signal  and says SOS only?  I have the same iphone that i have been using  for years. I have tried all the suggested troubleshooting steps and nothing is working. I apperciate your  prompet reponse  


Level 3

I have found this occuring a little more often over recent months too.


Primarily in certain areas where our TPG/vodaphone mobile network signal is often not strong, i.e. in & around the NSW 2428 & 2290 postcodes, among other areas.


It's suspected that Vodaphone's infrastructure (mobile phone transmission towers & transmitters) cannot cope with increased load due to increased customers via downstream companies like TPG over recent years, and hope that they will address this as a matter or urgency.


In our case rebooting phones, turning airplane mode on/off, moving outside buildings etc. often helps.


Hi @hazdeber


Welcome to the Community!


We tried to search for your account to no avail.


We've created an article that may help you resolve this issue.


If you are still not able to use the service, please send me a PM with your mobile or customer ID number to assist you accordingly.