TPG Community

Get online support

MyTPG App give Network Error!!

Level 2

Recently changed phones and now can't use the MyTPG app as it comes back with "Network Error".

It worked on the old phone. Both the old and new are Android phones from Motorola, so standard Android.


Private DNS has been disabled and device is running Android 13.


How can we get this to work?


Hi @ant1000


Just to confirm, were you able to install it or just won't let you log in after you got it installed? 


Please send us a private message and we'll assist. 



Level 2

The app installed fine.


The issue is when you try to login a message box displays with the words "Network error".

Looks like some sort of time-out.


Have tried using wi-fi and mobile data network (not TPG mobile)

Level 2
Mines doing it too. Worked fine on previous phones but my google pixel phone it's just giving me network error. I tried on my old Samsung just now and it logged me in straight away. Ive only had this phone since October but I swear I've used the app on this before.