Level 2

Download date: 08-Jun-2020 -- because there is no version details in the app?

Device: iPhone 8 Plus

O/s: iOS 13.5.1


Question: Is your app still in beta?


Issue 1. Authentication details (User ID / Password) needs to be entered each time the app is opened. This is not hard - and there is no justification for it given the current standard-practice (i.e. don't let your business people make these decisions)


Issue 2. 'Update Your Details' data entry. Select field to update (e.g. 'mobile number') and the keyboard functionally disables the 'Update' button. Result: Mobile number not updated.

Note: I tried this on another field and the same issue. You can't scroll (down) to select the 'update' button (due to patterns that have been part of the iOS playbook ... forever)


Issue 3. Deleting the app. This worked.


Question: How did the business representatives let this out into production? (I'm assuming that you gave them access to a single emulate -- maybe Windows Mobile -- and convinced them that it would 'work the same for other devices'.


Issue: Professional integrity -- or competence?