Level 2

I'm looking to sign up for ADSL2+ off-net 200GB with TPG (best I can get at my new house!)

I already have 2 modems from my previous address.

First is from Telstra for ADSL2+ and is a
Technicolor TG587n v3

Second is from My Republic which was meant for an NBN service that they never delivered. It is a
Technicolor TG789vac v2 HP

I just want internet (no need for home phone). Are either/both of these suitable for use with TPG ADSL2+ off-net or do I need to buy another one when I sign up?

Thanks in advance.

Hi @Fraser,


Welcome to TPG Community!


In order to sign up for our ADSL2+ Off-net 200G, you need an active phone line. This phone line will be used for us to provide the internet service. If you have an active home phone from Telstra or other provider, that will do.


The Technicolor TG587n v3 which you received from Tesltra, should work given that you have been using it for ADSL2+. However, we need to make sure that the settings is not locked with Telstra. You can contact them for clarification.


The Technicolor TG789vac v2 HP which was given by My Republic is a VDSL modem. Since it will be using the same DSL line, then it is possible to work. We just need to make sure that the configuration of it is correct.


You don't need to purchase a new modem if your old modems are still working fine.


If you need assistance with your order, please call our Sales team at 13 14 23 (Opt. 1)


Kind regards,

Level 2

How to configure Technicolor TG789vac v2 HP modem (came with previous connection with MyRepublic) to use ADSL+ connection wih TPG. I have selected WAN type as ADSL and chosen PPPoE by providing my user creds provided by TPG. But, my Internet connection keeps on showing status as "Connecting" but does not connect to internet.



Hi @miabhi0901,


Welcome to the community!


In case you need a reference on modem configuration settings for ADSL2+.


You can visit this link ADSL2+ modem general settings.


Have you tried to check the manual of Technicolor TG789vac v2? There are some modem/router that requires the username a 'domain' given by your previous provider.

i.e username:

Let me know how it will go.



Level 2
Thanks for suggestion buddy.
I tried providing username with domain as suggested but unfortunately, it didn't work. Its still showing PPP as "connecting" but doesn't connect.


Hi @miabhi0901


I can see that you're case is being handled by our Engineering team and they've now requested for a new modem. 


We'll chase this for you and will provide you an update as soon as additional information becomes available. 




Hi @miabhi0901,


We understand that you were able to be in touch with our Tech team and the free modem has been requested to replace your current one as it is faulty.


Updates will be provided by your case manager once available.


Should you require further assistance, please let us know.


Kind regards,