TPG Community

Get online support

ThinkPad P14s Gen 4 (14″ Intel) Mobile Workstation ADSL2+ Installation Troubles

Level 2

Hi Everyone

I hope this message finds you well. I'm reaching out for some assistance with installing ADSL2+ on my ThinkPad P14s Gen 4 (14″ Intel) Mobile Workstation. Despite my best efforts, I've encountered some difficulties, and I'm hoping someone here might be able to lend a hand or share some insight.


Here's the issue I'm facing:


Problem Description:
I recently purchased the ThinkPad P14s Gen 4 (14″ Intel) Mobile Workstation, which has been performing excellently for my work needs. However, I am now trying to set up a stable internet connection using ADSL2+ technology. Unfortunately, I haven't been able to get it up and running despite following the usual installation procedures.


What I've Tried So Far:

Modem and Router Setup: I have connected the ADSL2+ modem to my telephone line and connected the router to my ThinkPad P14s workstation using an Ethernet cable.


Configuring Router Settings: I accessed the router's web-based configuration page and tried configuring the connection with the necessary login credentials provided by my Internet Service Provider (ISP).


Troubleshooting ISP: I reached out to my ISP's customer support, and they confirmed that the issue is not on their end and that my line is active.


Updating Drivers and Firmware: I have ensured that all the drivers and firmware related to networking on my ThinkPad P14s are up to date.


Thank You


Hi @johnharries . Are you sure you are on ADSL and not NBN?

What model router do you have?

You've logged in to router admin so your computer is fine.

Apart from your username and password, what other parameters do you have?

What is the state of lights on router?
Anything in the router's system log?