TPG Community

Get online support

Air Print issues with 5G

MichaelSyme
Level 2

I've just replaced a Canon printer with a new Epson one, and neither of them show up when searching for air printers on iPhone or iPad. Everything's on the same network. Have tried restarting everything. Laptop prints fine through wifi. Is this a known issue with TPG 5G Broadband?

11 REPLIES 11
david64
Level 15

Hi @MichaelSyme . Is your laptop connected by ethernet? 

If it is, can you try this test? Remove the ethernet cable and connect the laptop to the Sagemcom via wifi.

Try your print again.

If it fails, it's AP Isolation preventing wifi devices communicating with each other.

You can have a look through the Sagemcom admin to see if this setting exists.

I've asked TPG to come clean on wifi settings for this model.

MichaelSyme
Level 2

No, everything is done by wifi. Will look at Sagemcom. 

david64
Level 15

@MichaelSyme . Well, that's interesting. It's not AP isolation stopping it.

Can your laptop ping the ipad and iphone?

On the ipad and iphone, how is the printer defined?

Is it by ip address? This may have changed with the new printer.

MichaelSyme
Level 2

Well, everything I've read about air print means it should just show up to be selected if it's on the wifi network. But the fact that two different brands of printers can't be found makes me wonder if it's a TPG issue.

 
 
david64
Level 15

@MichaelSyme . Really need to know if your laptop can ping the printer and the ipad and iphone.

The devices should tell you their ip addresses or look in the router admin at network status.

 

Did you recently change to 5G wireless and notice that Airprint on ipad and iphone didn't work.

Do you still have the old router? If so, can you check the wireless settings for AP Isolation. If you haven't factory reset it, that setting will be as you left it. Presumably, everything worked fine with it.

 

You could even go one step further and connect everything to the old router. Check that Airprint works on ipad or iphone. Then enable AP Isolation and try print again. You don't need an internet connection.

 

MichaelSyme
Level 2

Thanks David, I appreciate your interest and help. I can ping my iphone fine. I'm pretty sure the issue started when I changed to 5G wireless. Unfortunately I no longer have the old router. I can work aroud using my new printer's remote printing function i.e. emailing it with docs. Just annoying.

 

I found this on TPG Community from a moderator:

 

Hi @BobC ,

Any home smart appliances/devices will not work with 5G home broadband as it comes with CG-NAT
What is CG-NAT and how does it affect Home Wireless Broadband Services?

Techy types should be aware that Home Wireless Broadband uses CG-NAT. Carrier-grade NAT (Network Address Translation) is a type of network that assigns services with a private IP address, instead of a dynamic public IP address. Our network will then translate that private address into a public address. This means that the following items (which depend on internal NAT) will not work on Home Wireless Broadband:

Port forwarding985
Smart Home systems (e.g. accessing security camera footage remotely, home automation and printers)
Remote Access (i.e. accessing your home computer or devices from another location)The only way to for the device to work with the internet is to switch back to NBN connection. We can arrange our Plan change team to contact you to help us do this.

If you wish to proceed with change of plan, shoot us a PM with your details.

 

 

Does that make sense to you and does that mean TPG 5G Wireless doesn't support Air Print? All of this stuff is a bit too techy for me. 

 

Thanks.

 

david64
Level 15

@MichaelSyme . CG-NAT affects the interface betwen your router and the internet. It stops you from connecting in to your smart home devices (game server, cctv, fridge) from the internet. It doesn't stop local activities, from one device to another.

The wifi laptop works with the wifi printer.

The wifi laptop can ping the iphone.

That indicates AP isolation is not the issue.

 

Does either printer have an ethernet interface? That would take wifi out of the picture.

 

On Sagemcom, can you disable one wifi band or the other? Force all devices for certain on one band.

MichaelSyme
Level 2

Ah, I see what you're saying. Sagemcom tells me that the printer is on 2.4 while my iphone is on 5 Ghz. But I'm not sure how to force any of them to change and with my low level of tech knowledge, I'm loathe to fiddle with things I don't understand. I may have to pay an expert to come over. Tried talking to TPG support on the phone yesterday but the person I spoke to seemed to have less tech knowledge than I do - and that's a frightening situation. Thanks for your advice - at least I have greater understanding of what the issue may be.

Angeli
Moderator

Hi, 

 

To disable the band steering of the modem through its settings, simply create a different name for both 2.4Ghz and 5Ghz Wireless network name. This will automatically remove the band steering of the Wireless network.

 

Regards, 

Angeli