TPG Community

Get online support

Enable to get Minecraft to work ouside of the local network

sbenjamin70
Level 2

I am having trouble establishing a Minecraft game using the TPG router. My source device is an IOS device and the destination is Windows PC. I am able to connect from my PC via TPG Archer VR1600V modem to my friends IOS device, playing well with no issues. When I start a world they are unable to connect to my game

 

When I use my mobile broadband (Telstra) we are able to cross play with no issues. As soon as I connect to TPG my friend fails to connect to my game.

 

I have set up a static IP address for my local PC and set up port forwarding under NAT setting for the default port (25565).

 

I did call TPG support but they told me this was too complicated for them so I am reaching out here an on Wingpool (err sorry Whirlpool) to see if I can find a solution.

 

Nat1.pngBind1.png

6 REPLIES 6
david64
Level 14

Hi @sbenjamin70 . Normally, Address Reservation (Network, LAN Settings) is used to assign a fixed ip address to the game computer, better to be outside the range of the dynamic pool.

Port Forwarding (not Triggering) is used to direct connections from outside to the reserved ip address. Is there only that one port that is used for Minecraft? Port forwarding needs rules for every port to be used.

When your friends try to reach your Minecraft, how do they find your ip address?

 

Regarding your mobile broadband (Telstra), how does that work. Is the game computer tethered to your mobile phone?

sbenjamin70
Level 2

Thanks For qick reply

,

In terms of Testing on Telstra Link - Yes - I tether the PC to my Phone and ensure my WiFi is disabled. This takes the TPG rout completly out of the picture. When we do this we can join in both directions. 

 

How does my friend connect - In theor Mindcraft App they see me online and simply find me in the finds tab and click on my world.JoinMC.png

 

Why Static IP -  I just tried this as nothing else worked - I will revert back to dynamic ip allocation and rely only on port forwarding.

 

Mindcraft ports - Default is 25565 as far as I know - Some post suggest that port 19132  is also used - I added this and 19133 to port forwarding (Triggered) just in case .

 

I actually did a wireshark capture during the session where my friend tries to connect - let me know if this will help solate cause (attached to my response)

 

 

sbenjamin70
Level 2

I noticed when I connected to their world I saw these ports being used - I added them all to the port forwarding rules

david64
Level 14

@sbenjamin70 . Fixed ip is needed for the game computer so it doesn't change so the rules always work. I was suggesting to use address reservation rather than ip/mac binding.

When you create a world on your Server, it must register the world (and your current public ip address) with a central Minecraft server so other people can see your world is available and connect to it.

I feel your should use Port Forwarding because requests are coming from outside. Triggering works by having the router look for a specific outbound port from the computer; I don't believe the game works that way.

Wireshark is good to use because you can see the connection coming from the interrnet. You can use your phone's mobile data and browser to send a request to your game server to test the forwarding rule.

Get your public ip address from the router. In the browser URL, put your ip address followed by :25565

In Wireshark, you should see a SYN packet to port 25565. You can set a capture filter of   port 25565   or a display filter of    tcp.port==25565     .

 

sbenjamin70
Level 2

I have now doen some more isolation testing after ensuring the machine used a static / assigned ap and adding all the ports on a succesful connection.

 

I did a wireshark captur while connected to my Telstra dongle and saw all these ports being used by RackNet protocol (all UDP) - I added them all and we experienced the same issue - Times out and disconnects

 

In game I see her connect to my world - She spwans in it (I see her Avitar) then it times out and she leaves. 

 

I have sent the succesful connect via Telstra to an IP Genius I know (CISCO trippled certified proppelor head) and he is analysing the trace to see if I missed anything

 

Basically port 25565 is not being used - but port 49801 is used on unsuccesful connection (while on TPG) but port 57562 is used on succesful connection using Telstra dongle.

 

 

sbenjamin70
Level 2

I have decided this is an application issue and has nothing to do with my NAT settings. I did another test

 

1) Connected iPad to Telstra network 

2) Connected Windows Machine and started Game 

3) Connected from iPad to Windows world

 

Worked fine

 

As soon as I tried to use iPhone to connect it failed

 

When I did a packet capture I noticed the Raknet messages were malformd from the iPhone, but the iPad was 100% ok 

 

Will raise this to Microsoft and Apple support now with the packet captures to help drive their investigation.

 

In the mantime I am gifting my friend a windows laptop so we can play minecraft together Smiley Happy