FTTC no internet

Level 2

I tried to setup the NCD and router and everything seems to be okay but the internet light is not present. I have old school telephone socket and I attached the telephone cable with help of an adaptor(610). I have two sockets and troubleshooted with both. However, I tried basic troubleshooting such as turning off both NDC and router and stayed for while but the internet lights are the main issue now.
Please do the needful.

Thank you


Hi @abhistgajjar ,


For new services, we recommend customers to check if their service has been installed and activated.


We have created this community article, which contains a video on How to track your TPG service installation


We also send an email notification once the service is activated.


If you have received this email and the service is still not working, we recommend to check if the equipment is properly set up and we have created setup guides for all technologies that TPG use : New Connection Setup Help


For us to further assist you, please send us a private message with your TPG customer ID, username and complete address so we can pull up the account and help get to the bottom of this.


To send a PM, please refer to this link: How do I private message (PM) in the community