TPG Community

Get online support

How to Change NBN Plan Online via TPG My Account

Level 2

I have tried on computer and ipad and every time it gives an error message when I click to finally submit. I tried putting in fresh credit card details but it still doesn not work. I have tried ever day for a week. I have tried to email for support but get no answer. The online chat does not work. It will not let me reply to the operator and they always end the chat. I am highly skilled on the computer - I am doing everything correctly. This is not user error. Please will someone just phone me or email me and read my response. I just want to upgrade my plan. 

Level 2


I recently have the NBN Cable Broadband SL Bundle Standard installed at my house, however, I am wondering if I can upgrade to NBN Standard Plus ($69.99 /month). I have tried to follow the instructions to change plan from"My account" but I receive the error:

Unfortunately there was an unexpected error when submitting your registration.
We apologise for the inconvenience caused.
Please contact TPG Customer Service on 13 14 23 for further assistance.
When contacting TPG, please quote this error code: < E:adsl_comm:thread_exists >


I also tried to call the number but no one available on call. I also tried to start the PLAN CHANGE & MOVING HOME LIVE CHAT for over an hour and receive the message: 

  • Our team members are currently serving other customers. We appreciate your patience. Please try again later.

Would you be able to assist me with my enquiry to change plan? Thank you.


Level 2
Hey brisbane i am in exactly the same situation as you did you manage to get the plan changed either through emailing them or through the my account section of the user portal ? If so could you pls share how you actually did it because this online chat situation is just ridiculous its taken me 4 days of going around in circles and getting the chat window closed on me by the operators after being so called “transferred”
Level 2



I have tried doing this a number of times and keep on getting error messages. I just tried again now and got this


When contacting TPG, please quote this error code: < E:validate:mandatory:%cc_token E:validate:mandatory:%cc_num E:validate:mandatory:%cc_type E:validate:mandatory:%cc_expiry E:validate:mandatory:%cc_token E:validate:mandatory:%cc_num E:validate:mandatory:%cc_type E:validate:mandatory:%cc_expiry >

Level 2

I have had the exact runaround

Probably they dont want us to upgrade !!!!


Level 2
Hi can you please update the contract to a bigger plan as it is not possible to do it online as the only update contract is for ADSL not NBN
PLUS when I logon to ADSL to change the plan it states the logon details are incorrect when they are correct
The steps to change the plan do not work as there is no NBN change plan prompt
I have been online in a chat since 1pm and no one help me.
Extremely upset as this time has been spent on a Telstra hotspot to rectify a TPG NBN issue !
Level 3
Your process at present is way beyond Crap. Mr David Teoh should open up his wallet and pay all his staff and all his customers for puting up with the jack ** service TPG has been delivering for the past month.
Level 2

we have also been trying to upgrade for over a week now , getting error in plan,

took multiple times on chat to even find out that you can email but no response from that either.


we have tried calling and have managed to get through to someone and then they have not been able to upgrade and thus trying to put us through to support just to have call drop off.


Really not happy. Will be reporting to the Ombudsman.

and moving my service and my dads NBN service to another provider.

Level 2

just called and managed to get someone, they told me that they cant upgrade cause of a pending copper ADSL disconnect and phone number porting.


I was trying to ask him how is that got to do with the current NBN12 service working on FC coax and to upgrade to NBN50 in the meantime and he hung up on me cause he would not explain.


Thats it , no more TPG after this. Right now we cant work from home due to speed limit ... 


TPG = **

Level 2
This doesn’t work.. I keep getting an error and it asks me to contact you guys and your agents are not helpful either . This is ridiculous