TPG Community

Get online support

My mobile suddenly won't connect to wifi.

SOLVED Go to solution
Highlighted
Level 3

 I see the network name but when I try to enter the password it says  'password incorrect' or "unable to join network". This just happened yesterday,  was completely fine up till then.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 8

That's great news carolbee, it won't hurt to leave the laptop on either network, if you're doing a lot of streaming of 1080p or higher content it will probably take the load off the slower 2.4ghz band by connecting to the 5ghz network, in practice though I've found the 2.4ghz network to have better, albeit slower coverage using a HG659 but that totally depends on your premises.

Do some experimenting with individual devices by connecting to both networks one at a time and do a walk around your home to see what coverage is better. For general browsing and social media etc I doubt you'll notice a difference between bands. Good luck

View solution in original post

13 REPLIES 13
Highlighted
Level 8

Hi @carolbee, Welcome to the community, have you tried a simple restart on the modem router? Which model are you using? Is it a 2.4ghz or 5ghz WiFi channel that's affected or both?

Highlighted
Level 3

Hi and thanks for the reply,

I have tried the restart and I just disconnected everything and plugged it all back in, turned the mobile back on and still no change.  The modem uses a 5Ghz channel. It works ok when I go out and use the wifi in cafes and stores and my laptop is unaffected.

Highlighted
Level 8

Thanks for the info @carolbee, can you try and delete or forget that connection on your phone and try a new connection, do you know what model router it is and what brand and model phone do you have?

Highlighted
Level 3

Sorry but I don't see an option to delete or forget a connection.  It's an iPhone 4 and the router is a Huawei HG659.

Highlighted
Level 8

Ok @carolbee I can see a problem right there, the iPhone 4 and 4s only support WiFi on the 2.4ghz band, they don’t support 5ghz, try connecting to the 2.4ghz version of the HG659’s WiFi network only and see how you go.

Highlighted
Level 3

Well it's kind of weird that it would happen now, because it has been fine up till now, ever since i got the phone at the beginning of this year.  Also I don't know if this is relevant but there were a couple of storms over the weekend and for a while afterwards I had a problem getting photos to download in Facebook on both the mobile and computer on Sunday. It wasn't till yesterday (Monday) that I noticed the mobile wasn't using the Wifi, only the mobile network. 

 

Highlighted
Level 8

It's certainly possible that storms could've corrupted things in the router but usualy a reboot will bring them back, I'm confused about your iPhone 4 though, are you sure that's what it is? An iPhone 4 won't even see a 5g SSID in it's available network list. Have you tried connecting to the non 5ghz network yet?

Highlighted
Level 3

Yes it's definitely an iPhone 4.  And yes i've tried to connect on the other network, but it still won't let me join although now it doesnt say I'm unable to join, it tries for about 2 minutes but just keeps going back to the dialogue box "Enter the password for ... "  I just clicked on the blue information symbol beside it and yes there is "Forget this network" as you previously mentioned. 

Highlighted
Level 8

Hi @carolbee. Can you connect any other device such as your laptop to the 2.4 ghz only channel on the HG659?

 

I've just connected 2 different iPhone 4 devices to a HG659 with no problem, they're both running iOS 7.1.2 which is the final version for that model.

 

On your iPhone can you go to settings>general>reset>reset network settings and try a new connection.

The HG659's WLAN settings should be security mode: WPA2-PSK / WPA encryption mode: AES / Transmission mode: 802.11b/g/n see how you go.

 

IMG_0070.JPG