TPG Community

Get online support

Remote Desktop keeps dropping out almost as soon as I connect.

Level 2



connected to NBN the other day and all seemed good, Netflix no problems, speed tests suggest I am getting the speeds promised.


But today I tried working from home. I could establish the VPN channel but every time I Remote Desktop it worked for a minute or two then the connection is dropped. The software reconnects and I get a bit more time then it repeats. Happened all day and I was the only one in the house so not conflicting with anyone for the bandwidth.


Any suggestions what the problem might be? Or more importantly what the fix is.




Hi @xyloidhead,


What troubleshooting have you done so far with your connection? I ran an initial test on your service it shows connected for 2d 1h 10m with a good connection to the line.

Also, have you tried to contact the support of the software you're using?

Perhaps, refreshing modem/router connection may fix the issue you can try to turn on/off the modem/router for 2-3mins and turn it back on again.


Let me know how it will go.

Level 2

Interesting, turning off the cable box and modem appeared to help. Only had time for a 15min test but it held the Remote Desktop session for the entire 15 minutes. Alas I didn’t have time to rest it before I turned it all off. Worked while streaming Netflix for family.


i’ll test It a few more times this week and see if it continues to work, before I can trust it enough to try working from home again, sigh.


thanks for the help, will be back if it hasn’t actually fixed it.




Glad to hear that the service is now up and running, xyloidhead


Should any assistance arise, please feel free to contact us again.