TPG Community

Get online support

Swann Tracker Security Camera not reconnecting automatically to wifi after power cycling

Bry
Level 2
Level 2

My Swann Tracker Security Cameras are not reconnecting automatically to wifi after power cycling. Is it because I'm using TPG Home Wireless Broadband? Do I need to change any router settings?

9 REPLIES 9
david64
Level 13

Hi @Bry . Do your other wifi devices (phone, tablet) reconnect automatically? If so, it may be a camera setting? You can ask Swann.

Is the camera missing from the client list when you check in the TPG router?

Being on home wireless broadband, you cannot access the camera when away from home, because of CG-NAT.

Bry
Level 2
Level 2
Our phones and laptops have no problem connecting and reconnecting to wifi.

The wifi cameras are on the client list of the router.

I saw the Cg-nat post, however i do not find any problems accessing the wifi cameras outside the house.

Swann already updated the firmware of the cameras several times but the wifi reconnection issue still persists. I don't want to change my wifi cameras with out consulting TPG
david64
Level 13

@Bry . Just to clarify. You power cycle the router and then find the wifi cameras in the router client list. This means they have reconnected. Do they get an ip address? What is the reconnection issue?

Do the cameras upload video to Swann or just store it on the internal memory card? Or, do you have a network video recorder?

When I said "away from home", I meant far away that you use mobile data, not the wifi. Do you use the Swann app to access video remotely? Does the app connect to Swann to show video?

Bry
Level 2
Level 2

I use Swann app to access video remotely. I do not have any problems accessing that app using mobile data. The Swann app connects to the cameras to show video using mobile data.

 

The cameras have an internal memory card only. They do not upload videos, no nvr.

 

After power cycling the router, the cameras are in the client list. They get an IP address. 

 

My issue is when the cameras themselves do power cycling, they do not reconnect to the wifi automatically. I need to hard reset and reinstall the cameras to be viewable again via Swann app. I already got in touch with Swann . They updated my cameras a few times but the issue has not been addressed.

 

Is this a TPG Home Wireless Broadband issue related to CG-NAT or Swann camera issue? 

david64
Level 13

@Bry . You can check the dhcp messages in the router log to see what happens when a camera turns on. 

You could give each camera a fixed local address outside the dynamic range used by the router.

Bry
Level 2
Level 2

How to give each camera a fixed local address outside the dynamic range used by the router?

 

david64
Level 13

@Bry . The router keeps a pool of ip addresses for when devices connect. The range might be from 100 to 199. Look in the client list. It shows the MAC addresses of the cameras. In the address reservations section, assign an ip address, eg. starting at 192.168.1.11 for the first camera, then 12, 13, etc. When a camera reconnects, the router will always give it that address. 

Just stepping back a bit, you said the camera doesn't connect to wifi automatically. How do you configure the camera in the first place? It has to be told the wifi network name and password. Are there any other settings?

Bry
Level 2
Level 2

To configure the cameras, no other settings except for wifi network name and password.

 

I assigned 1of the cameras on a particular IP address, however, it still does not automatically connect to wifi after power cycling.

 

david64
Level 13

@Bry . Is there anything in the router system log at the time you power cycle the camera?

 

Do you have a wifi router from before or can you borrow one? It doesn't need internet connection. Set it up out of range of your current one. Set the camera for the different wifi details.

 

Can you take a camera to a friend and try it their router?