TPG Community

Get online support

Thread: 3 Win 10 PCs/All Download Speeds Dropped from 1 Gigabit to 200 Mbps!

Level 1

Hi, first time posting, really would appreciate help. Comcast 1Gig service worked from December 2017 until about 2 mos ago. 3 pcs all running Win 10 Pro affected. Problems exists in Firexfox, IE, Edge and Chrome! Output of Arris SB8200 modem tests indicate 1.1Gb/sec on Comcast test rig running Safarai. 2 desktops are running Gigabyte boards with two different LAN cards. 3rd pc is a Toshiba laptop with a different LAN card. All ethernet connections are CAT6 cabling.All 3 pcs running Win 10 direct connect to modem test (Ookla) at 200 - 300 Mb/s. All 3 pcs booting to Linux test at about 980 Mb/sec behind router and switch! 

Definitely appears to be a Windows issue and so far Microsoft has not come up with a solution. ALL tweaks suggested on Internet have been tried. Msft also did a new install of the October Windows Update in case that had somehow created a problem. I am pasting the results of the SC TCP/IP Analyzer and some system info below. Any help will be greatly appreciated!

SG TCP/IP Analyzer

IP Address: (
Client OS: Windows 10
Browser: Firefox 66.0
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
Please Read the Analyzer FAQ if the above is not your IP address.
TCP options string = 020405b401010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which equals MSS.
Default TCP Receive Window (RWIN) = 64240
RWIN Scaling (RFC1323) = 0 bits
Unscaled TCP Receive Window = 64240

In Windows 10, unless "TCP/IP Auto-Tuning" is disabled, only the Current TCP Window is displayed. Use the latest TCP Optimizer for tweaking.
RWIN is a multiple of MSS
Other RWIN values that might work well with your current MTU/MSS:
64240 (up to 2 Mbit lines, depending on latency. MSS * 44) <-- current value
128480 (1-5 Mbit lines, depending on latency. MSS * 44 * 2)
256960 (2-15 Mbit lines, depending on latency. MSS * 44 * 2^2)
513920 (10-30 Mbit lines, depending on latency. MSS * 44 * 2^3)
1027840 (30-100 Mbit lines depending on latency. MSS * 44 * 2^4)
bandwidth * delay product (Note this is not a speed test):

Your current TCP Window limits you to: 2570 kbps (321 KBytes/s) @ 200ms latency
Your current TCP Window limits you to: 1028 kbps (128 KBytes/s) @ 500ms latency
MTU Discovery (RFC1191) = ON
Time to live left = 115 hops
TTL value is ok.
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349) = 00000000 (0)


OS Name Microsoft Windows 10 Pro
Version 10.0.17763 Build 17763
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer Gigabyte Technology Co., Ltd.
System Model Z97X-UD3H
System Type x64-based PC
System SKU To be filled by O.E.M.
Processor Intel(R) Pentium(R) CPU G3258 @ 3.20GHz, 3201 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F7, 6/17/2014
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product Z97X-UD3H-CF
BaseBoard Version x.x
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.17763.194"
Time Zone Eastern Daylight Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.86 GB
Available Physical Memory 5.15 GB
Total Virtual Memory 9.74 GB
Available Virtual Memory 7.20 GB
Page File Space 1.88 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Thank you very much inn advance for any insight and suggestions!


@jamesbowers I would suggest a system restore? Restore it to the time in which everything was okay.