TPG Community

Get online support

Unable to connecting old iPad to 5G Sagemcom FAST 5866T (Firmware: SGJy100058)

Level 2
Level 2

The main issue I have is when I tried to connect older ipad to either 2.4Gh ot 5Gh, I get the error "Unable to join the network 'Network Name'". I have both different SSID for 2.4G and 5G. I have also tried changing from WIFI6 to WIFI5 but it did not work either. There is no option to disable 'band steering' in the menu tab either.


The issue is the devices that connect via WPA2-Personal previously does not work with Sagemcom WPA2/WPA3-Personal authentication, and there is no option to support WPA2-Personal authentication in the Sagemcom 5G modem.


Is there a newer firmware that address this problem?



Hi @knt


The 5G modem/router only supports the WPA2/WPA3 security option, if your devices are not compatible with the said security option, then they'll not able to connect it.


If you still have an old router or modem/router, then you may need to set it as an access point for you to be able to connect the old devices.