TPG Community

Get online support

Upload speed getting only 1mbps since upgrading plan to faster NBN50.

SOLVED Go to solution
kathdwyer
Level 2

Hi there,

 

since upgrading our service from NBN 12/1 to NBN 50/20, I'm only ever seeing slow uploads of <1mbps.  Downloads are good. 

We are using supplied TPG modem VX420-G2v, and doesn't matter if speed test is done through Ethernet or wifi. 

Have tried rebooting router a few times.

Can TPG check their end or reprovision our routers settings?
 

My username is ********.

 

thanks!

 

1 ACCEPTED SOLUTION

Accepted Solutions
kathdwyer
Level 2

To whoever might read this, the cause for the slow upload turned out to be hardware.  TPG sent a replacement modem (identical model), and uploads are now ~20mbps as expected.  

 

Extremely fast service and speedy replacment (came with return satchel too).  Thanks guys!

 

 

View solution in original post

6 REPLIES 6
Angeli
Moderator

Hi @kathdwyer

 

Can you please share your latest speed test results today? 

 

 

kathdwyer
Level 2

Hi Angeli, I sent you a PM with my details..

 

Below latest speed test today.

 

Screen Shot 2022-03-03 at 08.21.30.png

Angeli
Moderator

I will need to arrange a callback with our tech team to assist you on the phone as it requires further troubleshooting using a computer. May I have your preferred callback number and time today? 

kathdwyer
Level 2
Hi Angeli,

I PM’d you my mobile number. Thanks
kathdwyer
Level 2

To whoever might read this, the cause for the slow upload turned out to be hardware.  TPG sent a replacement modem (identical model), and uploads are now ~20mbps as expected.  

 

Extremely fast service and speedy replacment (came with return satchel too).  Thanks guys!

 

 

Angeli
Moderator

Hi @kathdwyer

 

We appreciate your feedback and we're glad that you are enjoying your TPG service. Feel free to shoot us a message if you need assistance in the future. 

 

Regards, 

Angeli