AP Isolation Disable

Level 2


My new chromecast says it can not connect to the wifi and that the AP Isolation needs to be disabled, how do I disable it?



Hi @robincox489,


Welcome to TPG Community!


We have located the account using your community details and we can see that you're currently using a TP Link VR1600v modem.


To disable the AP Isolation, you may follow the steps below:


1. Open your browser and in the address bar type and press Enter.


2. Enter admin for both the username and password and click Login. If you have changed the login credentials, please enter the current username and password for your modem interface.


3. You will see the home screen shown below. Click on the Advanced Tab.


AP Isolation.png

4. Go to Wireless > Advanced Settings page. Locate the AP Isolation section and untick the checkbox to disable the AP Isolation.


5. Click Save to make the settings effective.


Let us know if we can be of further assistance. Thank you.

Level 2
Hi Robin,

I am actually fixing the exact issue with my chromecast. No luck after disabling the Ap islaotion.

Just wondering if you have successfully setup the chromecast at the end?

Much appreciated for yr help.


Hi @Shyeu2,


Welcome to the TPG Community!


What sort of error are you getting when you try to connect your chromecast to the WIFI network?



Level 2

I also tried the suggested fix and it still doesn't work. Can anyone offer some advice?


What error message does it give you? In the event that you're trying to setup a 3rd party cast device we highly recommend to contact the manufacturer for further support to avoid misinformation troubleshooting with the equipment.

Level 2



I can't find this  In my Archer C7 Advance wireless setting.




Hi @bmil


Welcome to the Community!


In order to assist you further with your concern, you may need to contact TP-Link support as they are more knowledgeable with your device.



Level 2

To disable / turn off the TP Link Ancher 7(US) AP Isolation, Go to Advance then Go to System Tools> System Preference and then you will see the AP Isolation (see screenshot). If you do not see System Tools either scroll down on the left side bar of the TP link WIFI net or zoom out of the page and you will see it! (Believe me I had this problem and eventually figured out how to scroll on the exact menu).

My Chromecast still can't be seen on Google Home; although, its connected to internet and I can see it on TP Link WIFI webpage.