TPG Community

Get online support

ASUS DSL AC68U on TPG HFC

Highlighted
Level 3

I was able to make this work after a bit of trial and error ... hence I am not sure if all steps are relevant

 

Apologies, I don't have the luxury of creating step by step instruction but hopefully the links will help.

 

Be warned, it's  all over the internet that your router will not longer be supported after this process and also potentially  brick your router

 

1) Flashed the firmware using RT-AC68U merlin firmware. (https://uktechhub.com/forums/topic/rmerlin-asuswrt-merlin-firmware-and-the-asus-dsl-ac68u-pppoe/ ) . ADSL feature will be gone, don't know what else, but there are a lot of Merlin features that I'd rather have.

 

DSL-AC68U will look like the below after successful flash

 

image.png

 

2) Set-up router to use Dual LAN 

- I've set-up Port 1 as primary

- WAN - secondary

- Set-up in fail-over mode

 

3) Populate WAN details (user name password) as per the TPG supplied router. For some reasons, my password is not my account password but I copied what was in the TPG supplied router

 

4) The "not so" tricky part is to configure VLAN 2. I used a script for this

https://github.com/RMerl/asuswrt-merlin.ng/wiki/User-scripts

- https://superuser.com/questions/1384906/how-do-i-persist-vlan-settings-on-my-asus-rt-ac68-router

- use the services-start script, add the following code

#!/bin/sh
touch /tmp/000vlanconfigured
robocfg vlan 2 ports "1t 5t"

5) In the router UI, goto LAN->IPTV and set

- Select ISP Profile -> Manual Setting

- Internet VID=2, PRIO=0

 

6) The bits that I don't understand (further experimentation needed, time permitting).

- Since I have configured it to use Dual WAN, I was expecting that port 1 will connect to the internet (I plugged  my uplink to port 1). However, in the router, port 1  will not connect, then after x retries it will fail-over to the WAN, and then the WAN  will connect.

 

Hope I have not missed anything Smiley Happy

 

Highlighted
Level 3

Further experimentation, there is no need to configure it as dual WAN. It seems the router automatically use port 1 as the WAN port.

Highlighted
Level 1c
Will be giving this a go sometime this week and will report back. Thanks for the update btw much appreciated!
Highlighted
Level 2

Thanks @jigsaw .  I've installed the Merlin firmware ok, but have no idea how to access the /jffs/scripts folder, or edit content.

Would you mind explaining how to do this to a complete noob (me).  Thanks

Highlighted
Level 1b

!! As jigsaw mentioned above, be warned, it's all over the internet that your router will not longer be supported after this process and also potentially brick your router

 

I had issues trying to upload the RT-AC68U onto my DSL-AC68U - my DSL-AC68U didn’t like it Smiley Sad I probably downloaded the wrong firmware but digging around, I managed to get it to work with these step by step using the gnuton firmware Smiley Happy Credit to jigsaw for sharing his steps!

 

Started from jigsaw’s post:

Here we go!

 

1. Download the latest DSL-AC68U Merlin firmware fork of the Merlin RT-68U firmware from https://github.com/gnuton/asuswrt-merlin.ng
   a. Download just the RTX file (you don’t need to clone the Repo!)
   b. Tested successfully using DSL-AC68U_384.17_0-gnuton1_DSL_1.0.4.9.trx  on TPG FTTC / VLAN ID 2
2. Log onto DSL-AC68U Admin and restore to factory default
3. Configure laptop Ethernet adapter to static IP 192.168.1.10
4. Connect Ethernet to DSL-AC68U on “Router LAN Port 1” and open browser to 192.168.1.1
   a. It should show Setup screen - do nothing here
5. Power off the DSL-AC68U
6. Hold down DSL-AC68U Reset with a pin and power on the DSL-AC68U
   a. Wait until the Power Switch is “flashing slowly” and release the Reset button
7. Open browser to 192.168.1.1 and it should be be on a DSL-AC68U “firmware restore screen”
   a. Upload the earlier downloaded custom gnuton TRX file and wait about 5 minutes until Router comes back up
8. Open browser to 192.168.1.1
   a. Set admin password
   b. Whilst it’s trying to detect DSL (which will fail), click Skip Setup Wizard and configure wifi
   c. Click Complete
9. Navigate to WAN » Dual WAN
   a. Enable Dual WAN
   b. Primary WAN: Ethernet WAN on Port 4
   c. Click Apply
10. Navigate to WAN » Internet Connection
   a. WAN Connection Type: PPPoE
   b. Enable 802.1Q
      i. VLANID to 12 - (just set this to 12 for now)
      ii. 802.1P to 0
   c. Enter your TPG username and Password - Copy from the TP Link Archer router » Network » Advanced Screen
     i. Username will be something like username@tpg.com.au
     ii. Password is not your usual TPG account so check the TP Link Archer router
   d. This is the TRICKY PART!
     i. Open up the Browser Tools » Network Tab » tick the Preserve Logs
     ii. Click Apply
     iii. You will see the POST onto http://192.168.1.1/start_apply.htm
       a. Right click and click "Copy as CURL"
       b. You will end up something like:

curl 'http://192.168.1.1/start_apply.htm' -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:75.0) Gecko/20100101 Firefox/75.0' -H 'Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8' -H 'Accept-Language: en-US,en;q=0.5' --compressed -H 'Content-Type: application/x-www-form-urlencoded' -H 'Origin: http://192.168.1.1' -H 'Connection: keep-alive' -H 'Referer: http://192.168.1.1/Advanced_WAN_Content.asp' -H 'Cookie: JSESSIONID=e4f44662da2fb7b7ef991692f12345; asus_token=1xxoIxl45vhTxWr1QC4h3MQ12345678; clickedItem_tab=0' -H 'Upgrade-Insecure-Requests: 1' --data 'productid=DSL-AC68U&support_cdma=&current_page=Advanced_WAN_Content.asp&next_page=Advanced_WAN_Content.asp&group_id=&modified=0&action_mode=apply&action_script=restart_wan_if%3Brestart_stubby&action_wait=5&first_time=&preferred_lang=EN&firmver=3.0.0.4&lan_ipaddr=192.168.1.1&lan_netmask=255.255.255.0&ctf_fa_mode=0&ctf_disable_force=0&wan_unit=0&wan_proto=pppoe&wan_enable=1&wan_nat_x=1&nat_type=0&wan_upnp_enable=1&upnp_pinhole_enable=0&upnp_secure=1&upnp_min_port_int=1024&upnp_max_port_int=65535&upnp_min_port_ext=1&upnp_max_port_ext=65535&ewan_dot1q=1&ewan_vid=12&ewan_dot1p=0&wan_dhcpenable_x=1&wan_dnsenable_x=1&dns_fwd_local=0&dns_norebind=0&dnssec_enable=0&dnssec_check_unsigned_x=1&dns_priv_override=0&dnspriv_enable=0&dotPresets=-1&dnspriv_server_0=&dnspriv_port_0=&dnspriv_hostname_0=&dnspriv_spkipin_0=&wan_pppoe_username=username%40tpg.com.au&wan_pppoe_passwd=passwordFromArcher&wan_pppoe_idletime=0&wan_pppoe_mtu=1492&wan_pppoe_mru=1492&wan_pppoe_service=&wan_pppoe_ac=&wan_pppoe_hostuniq=&wan_ppp_echo=1&wan_ppp_echo_interval=6&wan_ppp_echo_failure=10&wan_pppoe_options_x=&wan_vpndhcp=1&wan_hostname=&wan_hwaddr_x=&wan_clientid=&wan_vendorid=&ttl_inc_enable=0&ttl_spoof_enable=0'


      c. Simply update the “ewan_vid=12” to “ewan_vid=2” and send the command to the router to set the WAN Port to VLAN 2!
      d. Note that once the page has been updated to VLAN 2, you won't be able to update any other setting through the UI as the javascript will not allow the VLAN 2. So you want to update all the relevant chages and do the POST to update the VLAN 2 last
      e. I was on Mac so I could use curl. If you are on Windows, use https://www.postman.com to POST the above
11. Navigate to Administration
   a. Enable JFFS custom scripts and configs
   b. Enable SSH on Port 22 (LAN only)
   c. Click Apply
12. ssh/putty to the router on 192.168.1.1

echo "#!/bin/sh" > /jffs/scripts/services-start
echo "touch /tmp/00vlanconfigured" >> /jffs/scripts/services-start
echo 'robocfg vlan 2 ports "4t 5t"' >> /jffs/scripts/services-start
chmod 755 /jffs/scripts/services-start

13. Connect the Router LAN 4 to your NBN FTTC device with an Ethernet cable
14. Reboot the router and bobs your uncle!
   a. Quick test, connect your laptop to DSL-AC68U wifi and ping "8.8.8.8" to see if that works
15. If all is good, navigate back to Administration:
   a. Disable SSH on Port 22
   b. Click Apply

 

Successfully validated this on TPG FTTC on ASUS DSL-68U with the FTTC NBN Device!

 

ASUS_DSL68U_FTTC_NBN.png

 

Highlighted
Level 3

@mpsmart87 you can use steps 11 and 12 in @techie_one 's procedure. Note that in that procedure, port 4 is used so if you are using port 1 like I did, you have to use robocfg vlan 2 ports "1t 5t".

 

If you haven't used putty before and using windows, it is a free download. Just google it.

 

To test that you have set up the script correctly, reboot the router after you have it all working and that it will reconnect.

 

Highlighted
Level 2

Brilliant!!  Thanks @jigsaw  and @techie_one, you guys rock.  I've got it working and I can now ditch the default Archer/TP-Link router.

Highlighted
Level 2

Hi @jigsaw , @techie_one 

I hope you can help with this one too!

I'm trying to set up a USB samba share or FTP, but the router doesn't detect my USB drive.  I've tried Fat32 and NTFS formats.  Enable HDD Hibernation is set to No, USB Mode is USB 2.0.

Any suggestions please?

 

Highlighted
Level 3

I would suggest setting up a separate thread as it's not related to this topic, maybe raise it in another forum all together.

 

Having said, I tested it with USB3 memory stick and it works fine with no special configuration. Perhaps it's compatibility with your external device (eg. maybe the router can't supply enough power). I suggest trying with memory stick to check it's not your USB port that is broken.

 

 

Highlighted
Level 1a

THANK YOU techie1 (and Jigsaw!) for this.  We're on Internode FTTC but this process allowed me to continue using my DSL-AC68U.

 

A couple notes - one, don't do what I did and get it working then try to reload your old settings... I can't tell why, but it stopped connecting and I had to start over.

 

Second, a couple spots were unclear, though I muddled through.  For those less lucky and/or experienced:

  • when it's talking about opening "Browser Tools -> Network Tab", in Chrome/Chromium that means to go into the Developer Tools - the little 3-dot menu, More Tools item, Developer Tools sub-item.  Then find the Network tab, check the box, and (optionally) clear out all other messages it's been recording using the button near the upper-left which looks like a circle with a slash across it, so you can more easily find the one you want.  It won't SAY it's a POST in any obvious way, but it'll show start_apply.htm as the destination. 
  • "Copy as CURL" is in a submenu of the context menu
  • At the step where you modify the command and then "send it to the router", that just means enter it directly into a command prompt/terminal.  Go back and reload your browser view to confirm it worked

I'm on Linux and from here, or OSX, it's pretty straightforward.  I assume Windows-only users can benefit from the Postman app he mentions.

 

I've also spammed this post to 2-3 Whirlpool threads where this subject is being discussed.  Thanks again!