TPG Community

Ask, answer and talk about our products


SOLVED Go to solution
Level 2

Can someone PLEASE help me. I have the ASUS RT-AC68U router. It was working fine, then one day came home and it wouldn’t connect saying something about DCHP settings. Tried resetting, updating firmware etc nothing. Thought the router was faulty, returned it. Got a new one. Tried to run quick setup. Still nothing!!! Will not connect.

Hi @Crusty77,


Welcome to the TPG Community.


I checked your account and seen that the internet is already working. Is your ASUS RT-AC68U router connected to a modem/router? If it is, instead of using connection type PPPoE, you need to use the connection type Dynamic on your ASUS router since your modem/router is not on bridge mode.


If it's still not working, please contact ASUS technical support since they have the proper training with their device.


Keep us posted for any update.


Level 2
Thanks for your reply. I’ll have a play and see how I go. Last time I contacted tech support. They said they couldn’t help as it was not a preferred model