TPG Community

Get online support

Google home cannot communicate with wifi

Highlighted
Level 1

I've been trying to connect google home with my wifi and it does connect. However it says it cannot communicate with devices due to the wifi settings. In trouble shooting it says to disable Access Point/AP isolation, also known as CLient Isolation or guest mode, on your router. Enable UPnP(UNiversal Plug and Play) also known as Multicast on your router. I've tried to find these settings and disabling/enabling with no success.

13 REPLIES 13
Highlighted
Moderator

Hi @notbadgoodisze,

 

Welcome to TPG Community!

 

What devices are you trying to communicate using the Google Home? Are they connected to the same network as your Google home?

 

Also, make sure that the Google Home is receiving a good signal from the modem/router network to avoid dropouts or interruptions with the connection.

 

We also tried to locate your account using your community details to no avail. Please shoot me a private message with your TPG username or customer ID number.

 

How to send a PM? Click here.

 

Kind regards,

BasilDV

Highlighted
Level 1c

I have exactly the same problem with my Google Home Mini. It was working fine until switch from ASDL to NBN.

Highlighted
Moderator

Hi @iangow71,

 

Welcome to the Community!

 

For us to understand better how we can extend our help, can you clarify the following:

  1. What device are you using to communicate with the Google Home Minit?
  2. Are they connected on the same WIFI network? The TP-Link modem has both 2.4GHz and 5GHz networks enabled. Please ensure that both are connected to the same WIFI name.

 

Regards,

Highlighted
Level 1c

1. An iPhone (acutally I've tried two different iPhones).

2. Yes. Connecting the phone and attempting to connect the Google Home Mini to the same network (either 2.4 or 5.0) has the same issue.

 

All was fine until I switched from ASDL to NBN (yesterday). 

Highlighted
Moderator

Hi @iangow71,

 

What is the error message that you've received?

 

Have you tried to uninstall and reinstall the application for your Google Home mini? If not, please perform it and try to reconnect again.

 

Keep us posted with the result.

 

Regards,

BasilDV

Highlighted
Level 1c

I tried that. Same result.

 

As mentioned, it appears that the device is connected to the same network as my phone, but something is preventing communication between the phone and the Google Home Mini device. This all worked prior to changing the router (from ASDL to NBN).

Highlighted
Level 1c

One more screenshot (last of 3) ...

 

The suggestions in "Get help" are:

 

1. Switch of AP isolation.

2. Turn on UPnP.

 

But AP isolation was already off and UPnP was already on. So I left those settings as they were.

Highlighted
Moderator

Hi @iangow71,

 

We've checked this issue within the Google community and it seems that it is a known issue with the device. You may refer to the discussion here.

 

Since the AP Isolation is already disabled on your TP-Link modem/router, we need to know if what settings do we need to change on your WiFi. Have you contacted Google support for some advise? If not, please contact them to check what exactly the changes we need to do with your modem/router in order to resolve this.

 

While waiting for their response, try to change the WiFi name, password and channel to check if it's going to do the trick.

 

Regards,

BasilDV

Highlighted
Level 1c

I have tried both sending feedback through the Google Home app and that Google support page. I don't think I will pursue changes to WiFi names, passwords, and channels: the device is connected. Not worth spending more time for a glorified cook timer/weather announcer.

 

Hopefully a fix comes through on either the TPG or the Google side and I will try that then.

 

Thanks for your help.