TPG Community

Get online support

How to connect an ASUS tuf-ax5400 wifi router to my Huawei HG659 TPG provided modem without having Double NAT issue ?

SOLVED Go to solution
alexandresilva
Level 3

I would like to have my new ASUS tuf-ax5400 router connected to the Huawei TPG provided modem without Double NAT , as at the moment the ASUS router is on 192.168.1.2 and the Huawei modem is 192.168.1.1. Wondering if there is a way where the ASUS router can get the external ip and them avoid the double nat issue. With the double nat i cannot use usb share and remote access to my ASUS router plus for gaming is not an ideal situation.I connected an ethernet port from the Huawei modem to the wan port of the ASUS router.

1 ACCEPTED SOLUTION

Accepted Solutions
BasilDV
Moderator

Glad that the factory reset helped resolve this issue.

 

Have a good day!

BasilDV

View solution in original post

19 REPLIES 19
david64
Level 13

Hi @alexandresilva . What type of NBN connection do you have? (Is there a NBN box?)

Do you use the TPG VOIP phone service?

alexandresilva
Level 3

Hi David

My NBN is Fibre to the Node. I do have a  phone connected to the modem but i never use the phone pretty much .

david64
Level 13

@alexandresilva . The HG659 is needed for the RJ11 connection to NBN.

If you want to keep the VOIP phone service, the Asus has to run in Access Point mode. There may actually be a setting for this; there's no user manual for this model. If there is no specific access point setting, just disable DHCP and NAT on Asus. You've already given the Asus a different ip address. Connect Asus to HG659 using LAN to LAN.

 

If you want to abandon your VOIP phone (change to PAYG plan and divert calls to your mobile), you can put the HG659 in bridge mode and run the Asus in normal mode. Asus does DHCP, NAT, and all other functions.

 

You need to get the Huawei into bridge mode to handle the VLAN ID setting. The Huawei then does nothing extra. But there's no instructions to put Huawei into bridge mode.

I did find this:

Refer to this TPG Support document:

Huawei HG659 Modem Configuration Guide

 

Proceed to page 3 of the PDF document.

Once you have logged in to the modem, click on Start Wizard.

By-pass instruction to enter your username and password and select the fourth option: Connect with another modem.

Click next and follow the succeeding instructions.

This will allow you to set up Huawei HG659 in bridged mode.

(You'll need to find where the VLAN ID=2 setting is done.)

 

Then configure Asus as  PPPoE, username + @tpg.com.au and password.

Connect Asus WAN port to HG659 LAN port.

 

alexandresilva
Level 3

Hi David

 

I will try this once i get at home later thanks for the advice. I will post here if got any lucky. 

alexandresilva
Level 3

Hi David thanks for the tips i did that and worked , setup my Huawei in bridge mode just through the wizard and choosing the option : Setup a connetion with another router and that is it. It fixed my double nat issue and now my ASUS router got the external ip, only issue is that i lost my voip phone but i never use my home phone pretty much so all good. 

alexandresilva
Level 3

Somehow i lost the internet connection on my asus tuf-ax5400 and cannot recconect like was before on this setup. Tried to replicate following the instructions that David passed above but no joy. Any tips or help to restore my internet connection ? tpg support is really not very helpful and not very techy savy . they keep saying is a third party router problem but i think it is the old hg659 modem not really working anymore in bridge mode.

I need this setup option because otherwise the other option suggested by David gives me double nat which is bad for gaming. 

Any help would be much appreciated. I already called tpg support twice . see pics for my asus setup.

BasilDV
Moderator

Hi @alexandresilva

 

We'd like to look into this further.

Shoot me a PM with your TPG username or customer ID number to assist you.

 

BasilDV

david64
Level 13

@alexandresilva . There might be an outage in your area. You can check at NBN or TPG.

Do a factory reset on HG659 and set it up for normal operation to see if the internet is working or not.  Then do bridge setup.

alexandresilva
Level 3

Hi there David tks for the tips. I did that yesterday and on normal operation, on the huawei hg659 connecting with user details works, only issue is when i try to do the bridge mode setup , i am not able to get my asus tuf-ax5400 to connect using pppoe and my details. Alos tried to setup the vlan id=2 on the asus router under advanced settings- lan - iptv , where you set the isp profile to manaul , and set the internet vid to 2 and PRI to 0 and hit apply to validate those settings.