TPG Community

Get online support

How to connect an ASUS tuf-ax5400 wifi router to my Huawei HG659 TPG provided modem without having Double NAT issue ?

SOLVED Go to solution
alexandresilva
Level 2

I would like to have my new ASUS tuf-ax5400 router connected to the Huawei TPG provided modem without Double NAT , as at the moment the ASUS router is on 192.168.1.2 and the Huawei modem is 192.168.1.1. Wondering if there is a way where the ASUS router can get the external ip and them avoid the double nat issue. With the double nat i cannot use usb share and remote access to my ASUS router plus for gaming is not an ideal situation.I connected an ethernet port from the Huawei modem to the wan port of the ASUS router.

1 ACCEPTED SOLUTION

Accepted Solutions
alexandresilva
Level 2

Hi David thanks for the tips i did that and worked , setup my Huawei in bridge mode just through the wizard and choosing the option : Setup a connetion with another router and that is it. It fixed my double nat issue and now my ASUS router got the external ip, only issue is that i lost my voip phone but i never use my home phone pretty much so all good. 

View solution in original post

5 REPLIES 5
david64
Level 13

Hi @alexandresilva . What type of NBN connection do you have? (Is there a NBN box?)

Do you use the TPG VOIP phone service?

alexandresilva
Level 2

Hi David

My NBN is Fibre to the Node. I do have a  phone connected to the modem but i never use the phone pretty much .

david64
Level 13

@alexandresilva . The HG659 is needed for the RJ11 connection to NBN.

If you want to keep the VOIP phone service, the Asus has to run in Access Point mode. There may actually be a setting for this; there's no user manual for this model. If there is no specific access point setting, just disable DHCP and NAT on Asus. You've already given the Asus a different ip address. Connect Asus to HG659 using LAN to LAN.

 

If you want to abandon your VOIP phone (change to PAYG plan and divert calls to your mobile), you can put the HG659 in bridge mode and run the Asus in normal mode. Asus does DHCP, NAT, and all other functions.

 

You need to get the Huawei into bridge mode to handle the VLAN ID setting. The Huawei then does nothing extra. But there's no instructions to put Huawei into bridge mode.

I did find this:

Refer to this TPG Support document:

Huawei HG659 Modem Configuration Guide

 

Proceed to page 3 of the PDF document.

Once you have logged in to the modem, click on Start Wizard.

By-pass instruction to enter your username and password and select the fourth option: Connect with another modem.

Click next and follow the succeeding instructions.

This will allow you to set up Huawei HG659 in bridged mode.

(You'll need to find where the VLAN ID=2 setting is done.)

 

Then configure Asus as  PPPoE, username + @tpg.com.au and password.

Connect Asus WAN port to HG659 LAN port.

 

alexandresilva
Level 2

Hi David

 

I will try this once i get at home later thanks for the advice. I will post here if got any lucky. 

alexandresilva
Level 2

Hi David thanks for the tips i did that and worked , setup my Huawei in bridge mode just through the wizard and choosing the option : Setup a connetion with another router and that is it. It fixed my double nat issue and now my ASUS router got the external ip, only issue is that i lost my voip phone but i never use my home phone pretty much so all good.