Huawei HG659 settings

SOLVED Go to solution
Highlighted
Level 3

How do I change the 5GHz channel number on the Huawei HG659 NBN router?

At the moment "Automatic" is the only available option. The problem I have is the channel number that the modem automatically selects (136) is not supported by my MacBook Pro and several other tablet devices I have. I would like to change the 5GHz channel number to one that is supported by my devices, but can't figure out a way to do this. 

 

Alternatively, is there a different brand of NBN modem I can buy that does allow me to set the channel number so I can actually have a working 5GHz connection.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 3

Thanks Basil,

 

I wasn't able to connect this afternoon, but having now gone back in to check the modem settings I noticed the firmware update you applied has indeed given me the option of manually setting the 5GHz channel number.

 

Have now set it to channel 60 and all 3 Macs are now connecting to the 5GHz network and I am writing this reply using it.

 

Thanks so much for your help, greatly appreciated.

Mark 

View solution in original post

8 REPLIES 8
Highlighted
Level 8

Hi @mhabgood Welcome to the community, you should be able to change the channel but you need to be in the advanced menu as the basic menu has limited setting options.

Highlighted
Level 3

Thanks. Not sure how to access these extra advanced settings. 

When I click on the Advanced button at the bottom, I am able to change the channel for the 2.4 GHz band from a large pull-down list, but there is no option to change the 5 GHz channel (its pull-down list only has the one option, Automatic). Unfortunately for me the HG659 automatically selects a channel number that I can't connect to with my Mac laptop, iPhone, Surface Pro, Samsung TV or Samsung Tablet. Are there alternative routers where the 5 GHz channel number can be user selected? I suspect the problem may have something to do with conflicting country codes, my router shows up as country code X1, whereas one of the neighbours show as AU.

Highlighted
Moderator

Hi @mhabgood,

 

Please see some of the screen shot for Huawei HG659's Wireless advance settings.

On this modem's page will help you on how to setup your both 2.4Ghz and 5Ghz wireless network.

 

 

HG659WLAN.png

 














HG659WLAN2.png


HG659WLAN3.png

Let me know should you require further assistance.

 

Cheers!

Highlighted
Moderator

Hi @mhabgood,

 

I'd like to clarify if you have access the WLAN's Advance settings. This should show you the advnace settings where you can channel.
 

Under home Network Tab > WLAN Settings > Advance Settings
 

If it does not give you other option to change channel for 5Ghz connection; you can try to change the transmission mode based on your device(s) compatibility.

 

Regards,

Highlighted
Level 5

@mhabgood

wireless 5g channel starts at 36 so using channel 1 on 5g is not possible.

Highlighted
Level 3

It turns out the 5GHz channel on the Huawei is automatically set and there is no way for users to manually set it.

 

I think it is time to give up on Huawei and switch to an alternative router/modem.

I am told the D-Link Taipan AC3200 will allow me to set the 5GHz channel to one that Apple computers can access and will plug into the NBN.

 

Has anyone tried this router/modem on the TPG NBN and will the bundled VOIP phone still work ? 

 

Highlighted
Moderator

Hi @mhabgood,

 

The wireless channel for the 5GHz network can be manually set. Are you able to provide screenshots of what happened when you visit the advance settings and tried to click the channel? We'd like to analyze it further.

 

The VoIP that is bundled with your TPG NBN service will not work with  any third party modem/router as the settings of it is embedded in its firmware.

 

Kind regards,

BasilDV

Highlighted
Level 3

Thanks Basil,

 

I wasn't able to connect this afternoon, but having now gone back in to check the modem settings I noticed the firmware update you applied has indeed given me the option of manually setting the 5GHz channel number.

 

Have now set it to channel 60 and all 3 Macs are now connecting to the 5GHz network and I am writing this reply using it.

 

Thanks so much for your help, greatly appreciated.

Mark 

View solution in original post