TPG Community

Get online support

Sagemcom 5866T firmware SGJy100214

pyrag63
Level 3

When will this version of the firmware be available to download or be updated automatically? I have an issue with Network device visability and settings that version SGJy100214 is meant to fix. 

7 REPLIES 7
BasilDV
Moderator

Hi @pyrag63 

 

Have you already tried to factory reset the device?

 

What troubleshooting have you tried so far?

pyrag63
Level 3
Yes I have reset it. I have discovered that it's caused by adding another AP to the network. Removing the AP or changing the AP into a Router fixes the problem.
BasilDV
Moderator

Glad that you've resolved it, @pyrag63 

 

Have a great day!

pyrag63
Level 3

That doesn't fix the problem as I meet to connect an AP to the 5866T and when i do so i have no idea what is connected to the 5866T. In fact when i look at the list of connected devices to the AP i suspect that none are connected to the 5866T even if the Wifi is still enabled on the 5866T. It would be good to know.  

shaunf69
Level 3

I'd like the newest firmare for this router too please, before I decide that this service and device is too buggy and cancel within first month. Cheers.

AshfieldUser
Level 2

I don't understand why TPG is so reluctant to provide firmware updates. It used to be easy to get the latest version, test for improvements and roll back if necessary.

 

Can someone from TPG please explain why I can't access any upgrades and install them at my own risk?

 

Many thanks in anticipation. 

shaunf69
Level 3

The Sagemcom got firmware version SGJy10021E a couple of weeks ago. Lots of stuff improved in there. Can now set a custom IPv4 DNS server for the DHCP service, and they've now enabled the USB-C port.

 

The dodgy IPv6 implementation is still present though causing certain apps to fail loading data etc. They've tried to stop the router from issuing IPv6 via DHCP/SLAAC after the first 5 minutes of it booting by the looks of it, but it doesn't quite hit the mark as your client devices will still get an IPv6 config within that time causing problems.

 

If you want to get away from that, raise a complaint and TPG will replace it with a Nokia Fastmile 5G 3.2 which is a much better router overall. Better signal reception, better IPv6 - can even disable IPv6 at the APN level too if you really want but it seems to be alright so far.