TPG Community

Get online support

Steps I used to connect Ubiquiti EdgeRouterX to TPG NBN FTTC

Level 1

This is not a question, rather it's my attempt to record the steps that I took to use my preferred modem.

 

I am a new TPG NBN customer, previously using ADSL2+ with TPG.

 

My home has Fibre to the Curb (FTTC).

As part of the TPG plan, I was supplied with an NBN box that provides power to the NBN fibre adapter in the telecoms pit near my house and also with a pre-configured TP-Link Archer 1600 VDSL capable modem / router / wifi point.

 

In order to connect to the NBN box using FTTC it's necessary to have a PPPoE connection. This is different from some other NBN connections, some instead require a simple Ethernet connection to request a DHCP IP address.

 

Initially, I connected with the pre-configured TP-Link Archer 1600 gateway. That worked, but I prefer the functionality of the Ubiquity EdgeRouterX (https://www.ui.com/edgemax/edgerouter-x/). Unlike many devices, this device's 5 Ethernet ports are separate interfaces. It's not just a 4 port switch with a WAN port, it can support 5 separate subnets, more if used with other VLAN aware equipment.

 

I could have simply used the Archer TP-Link as a gateway, turned off the wireless radios, then configured the WAN port of the Unbiquiti EdgeRouterX to have a fixed IP address in the Subnet the TP-Link was providing. Indeed, that's what I did initially until I figured out how to make the EdgeX directly connect to the NBN box.

 

Now that I've got that working, it's a slightly cleaner configuration. I may decide to use the TP-Link later as a wireless access point, but for now I'm just leaving it turned off to save power. It seems to get VERY hot when both wireless bands are turned on, so I'm assuming it's quite power hungry.

 

In case anyone else wants to use a Ubiquity EdgeRouterX to connect to the NBN box with FTTC with TPG, here's the steps you need to go through. I can't promise this will work for everyone, but it's working for me for a few days now.

 

---------------------------------------------------------------------------------------------------------------------------

 

Assumptions Made

------------------------

 

I am assuming you are using ETH0 as the WAN interface on the EdgeX.

I assume you initially used one of the wizards to create a sensible default configuration for the EdgeX. I myself used "WAN + 2LAN", then I re-configured it to remove the switch and effectively set up what I'd call "WAN + 4 LAN"

I assume you previously had ETH0 connected to some subnet as a WAN, such as I was doing using the TP-Link Archer 1600.

I assume you have some familiarity with the GUI of the EdgeX. Luckily you don't need to use the command like to do this.

 

Steps:

--------

 

  1. Directly connect ETH0 on the EdgeX to the NBN box with a suitable Ethernet cable.

 

  1. On the "Dashboard" screen of the EdgeX GUI, change ETH0 away from any IP address assignment to have an address of "no address". I was previously assigning it a static IP of 192.168.1.240, so it could work behind the TP-Link Archer 1600, which defaulted to a 192.168.1.x /24 subnet. So I removed that fixed IP address from ETH0. Leave other settings alone - e.g. the MTU can stay on 1500.

 

  1. Again on the dashboard screen, choose the "Add Interface" Button and choose to add a VLAN. Normally when setting up VLANS, we add VLANs to the LAN ports (ETH1 through 4), but here we are adding a VLAN with ID 2 to ETH0.

 

This step was one I didn't figure out for myself - I learned about this step from this web page: https://forums.whirlpool.net.au/archive/3rpmnwp3. A posting by "Silent Dog", near the end of that page. So the key parameters in this dialogue box are:

 

(a)VLAN ID of 2

(b) that the parent interface be ETH0.

(c) That the "Address" be "Use DHCP".

Other settings are less strict, but I kept an MTU of 1500.

 

  1. Now we can add the PPPoE connection. The mistake I was making to start with was that I added the PPPoE connection under ETH0. Instead, now that we have created the VLAN with ID2 underneath ETH0, we can now add the PPPoE connection under ETH0.VLAN2. To do this, we again choose "Add Interface" under the Dashboard screen. Then use these parameters:

 

(a) PPPoE ID = 0. This IS NOT the VLAN ID. Previously I thought it was the same, it's not. Set it to Zero.

(b) Interface = "eth0.2", so NOT "eth0", that would be the ETH0 interface, but not on VLAN2. We MUST use "eth0.2" to use the right VLAN ID that we created in Step #3. With other providers (say Telstra, iiNet...) the VLAN ID is likely to be different.

(c) Account name = My TPG account name. To my surprise, I could use just the username, without @TPG.com.au on the end.

(d) Password…. but in fact it seems anything works, even a blank password !

(e) MTU must be at least 8 less than that for ETH0 and for ETH0.VLAN2, so I picked 1492. I'm not certain that's optimal, but it works.

 

At this point, you may notice that the PPPoE interface of your EdgeX has a public IP address (e.g. 220.x.x.x). If you don't have that, there might be a problem. However even if you do see your address, there's still a step or two to perform. Don't stop here.

 

  1. Now we must change the rules for WAN Masquerade. I didn't do this initially and I couldn't connect to any web pages. Eventually, with a fair bit of TRACERT work, I figured out what I was missing.

 

To change the WAN Masquerade settings, we must go away from the Dashboard Tab, over to the "Firewall/NAT" tab. Then on that tab, in to the sub-tab of "NAT". Under that tab, we see one existing NAT rule, named "masquerade for WAN". Choose from the "actions" button at the right side of the screen, Choose "Config", now in this dialogue box, you will see the WAN Masquerade interface is "eth0". Change this to be "pppoe0". If you don't perform this step, you will be connected to the internet, but no traffic you send out will ever be returned properly. So you will have an IP address, but you can't browse to any websites, or PING anything. Basically this allows replies coming back from the internet to be properly returned through NAT.

 

  1. If you want to do port forwarding (as I do), you need to now visit the "Port Forwarding" sub-tab, on he "Firewall/NAT" tab. Here there is an option to pick which WAN Interface is used. This needs to change from "eth0" to "pppoe0", because the WAN interface is now that, not ETH0 as it used to be for most configurations. If you don't do this, outgoing internet connections will be fine, but external connections in (e.g. a VPN) won't work. These incoming connections are critically important to me, that's why I am paying extra for a static IP address.

---------------------------------------------------------------------------------------------------------------------------

 

I hope that's helpful for someone else.

Kind regards.

S.Davey.

 

1 REPLY 1
Highlighted
Moderator

Hey @S-Davey ,

 

Thank you for sharing this awesome guide. This is very helpful for the community.

 

Cheers!